<!DOCTYPE html>
<html>
	<head><script type="text/javascript">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</script>
		<!-- prefetch -->
		<link rel='dns-prefetch' href='//metrics.corus.ca' />
		<link rel='dns-prefetch' href='//www.facebook.com' />
		<link rel='dns-prefetch' href='//cdn.krxd.net' />
		<link rel='dns-prefetch' href='//beacon.krxd.net' />
		<link rel='dns-prefetch' href='//widgets.outbrain.com' />
		<link rel='dns-prefetch' href='//ping.chartbeat.net' />
		
		<!-- preload resource -->
		<link rel="preload" as="script" href="//native.sharethrough.com/assets/sfp.js" >
		<link rel="preload" as="script" href="//static.chartbeat.com/js/chartbeat.js">
				<link rel="preload" as="script" href="//fonts.smdg.ca/pzs6hjq.js" >
		<link rel="preload" as="style" href="//fonts.smdg.ca/k/c/pzs6hjq-d.css" >
		
					<link rel="preload" as="script" href="//widgets.outbrain.com/outbrain.js" >
				
			
					<link rel="preload" as="script" href="//assets.pinterest.com/js/pinit.js" >
		
			<link rel="manifest" href="/manifest.json">
			<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
			<script>
				var OneSignal = window.OneSignal || [];
				OneSignal.push(function() {
					OneSignal.init({
						appId: "f03e98ed-27f4-45d1-9642-8fdfd9a63005",
					});

					OneSignal.on('subscriptionChange', function (isSubscribed) {
						// Omniture tracking
						if ( isSubscribed ) {
							if ( typeof( OmnitureHelper ) !== 'undefined' ) {
								// Custom link tracking for notification subscription
								// To Do: Ask Phil to set up event in report suite to properly capture this data
								OmnitureHelper.trackLink( this, 'o', 'notification subscription' );
							}
						}
					});
				});
			</script>
		
		<meta name="google-site-verification" content="r0Dy4SR0u4Dh1nb6DA29xRZe3j_bgGMrTuXtB6gccuo" />
		<meta id="metaViewport" name="viewport" content="width=device-width, initial-scale=1.0">
		
<script async src="//js-sec.indexww.com/ht/p/183422-67482236234351.js"></script>
	<script type='text/javascript' async="async" src='//cdn.districtm.ca/merge/merge.v4.2.102566.js'></script>
			<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="x4SpOp2Us67I6MlQN2uFse9KXvwgu1d8_r5F2qkIbYc" />
<link rel='dns-prefetch' href='//fonts.smdg.ca' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Latest Entertainment News | Top Celebrity News, Hollywood Headlines &raquo; &#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217; Comments Feed" href="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/etcanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://etcanada.com/_static/??-eJytkNEOgjAMRX/I0RAlwQfjt5RRZVrGpF0If28R3nyRxJemze65tytMyYXoObck4EWgDaLQ8OCfjkMz4jiD6MxU9CEWJjiAEX6ISlFBO+qNkw4nR+o8RmwRbvYqEEy0ob9hS7pFgnCwcI/jkIV4Hdf6NyP3AXfYYUq7Pi/0ysROMMp6A+mI9Muizy5xvgdTPUgT2n5L2tYv8mt/KatzWR/Lqj69AcRGnvY=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script>
var gpt_ad_list = {"etc-gpt-lb1":{"sizes":[728,90],"pos":"1","companion":true,"biddable":true,"sizes_text":"728x90"},"etc-gpt-bb1":{"sizes":[[300,250],[300,600]],"pos":"1","companion":true,"biddable":true,"sizes_text":"300x250,300x600"},"etc-gpt-bb2":{"sizes":[300,250],"pos":"2","biddable":true,"sizes_text":"300x250"},"etc-gpt-band1":{"sizes":[340,100],"pos":"1","sizes_text":"340x100"},"etc-gpt-band2":{"sizes":[340,100],"pos":"2","sizes_text":"340x100"},"etc-gpt-band3":{"sizes":[340,100],"pos":"3","sizes_text":"340x100"},"etc-gpt-wall":{"sizes":[1,1],"pos":"1","out":true,"sizes_text":"1x1"}};
var gpt_ad_settings = {"adpath":"\/6872\/shaw.etcanada.com\/663253\/pride","targets":{"site":"etcanada","network":"shaw","page":"post","id":"663253","category":["movies"],"tag":["gay","high-school-musical","hocus-pocus","hsm","kenny-ortega","lgbtq","lucas-grabeel","pride","ryan"]},"amazon_bidding":"1","sizemaps":{"etc-gpt-lb1":{"728x0":"728x90","0x0":"320x50"}},"is_video_single":""};
</script>
<script type='text/javascript' src='https://etcanada.com/_static/??-eJyNjUsOwjAMRC+EG0WoUlkgzmISk48SN+SjFk6PF7BFlUaeWczzqK1AYJOGpaai6Dmovr42xXZS/wqQg6vYacqBf2WzcifuqnvKgjSPG1AHg4wWVUnDBW7KoPEEGHGXKPcYLfuY8b0y3IO1gR14SoXq8X35QN2AfRRA24S55aueL3o563mZ4wffw2L1'></script>
<script src='//fonts.smdg.ca/pzs6hjq.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://etcanada.com/wp-content/themes/shaw-et-canada/js/etc-watcher.min.js?m=1574204905g'></script>
<link rel='https://api.w.org/' href='https://etcanada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://etcanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://etcanada.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel="canonical" href="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/" />
<link rel='shortlink' href='https://etcanada.com/?p=663253' />
<link rel="alternate" type="application/json+oembed" href="https://etcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://etcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		
<!-- JSON+LD -->
<script type="application/ld+json">{"@context":"http:\/\/schema.org","thumbnailUrl":"https:\/\/etcanada.com\/wp-content\/uploads\/2020\/07\/HSM-FEATURE.jpg?quality=80&strip=all&w=720&h=480&crop=1","image":{"@type":"ImageObject","url":"https:\/\/etcanada.com\/wp-content\/uploads\/2020\/07\/HSM-FEATURE.jpg?quality=80&strip=all&w=720&h=480&crop=1","width":720,"height":480},"@type":"NewsArticle","mainEntityOfPage":"https:\/\/etcanada.com\/news\/663253\/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors\/","headline":"&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217;","datePublished":"2020-07-06T09:01","dateModified":"2020-07-06T09:07","author":{"@type":"Person","name":"Shakiel Mahjouri"},"publisher":{"@type":"Organization","name":"ET Canada","logo":{"@type":"ImageObject","url":"https:\/\/etcanada.com\/wp-content\/themes\/shaw-et-canada\/img\/logos\/etcanada-dark-small.png","width":60,"height":60}}}</script>
<!-- Meta Tags -->
<meta name="title" content="&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217;">
<meta name="author" content="Shakiel Mahjouri">
<meta name="description" content="&quot;High School Musical&quot; director Kenny Ortega has finally confirmed that Ryan (portrayed by Lucas Grabeel) is gay. Ortega, who himself is gay, confirmed the news while speaking with Variety about the queer aesthetic that runs through his films, and now actor Lucas Grabeel, who played Ryan has voiced his own reaction. RELATED: Billy Porter ‘Excited’&hellip;">
<meta name="keywords" content="Gay, High School Musical, Hocus Pocus, HSM, Kenny Ortega, LGBTQ, Lucas Grabeel, Pride, Ryan, Entertainment, Movies">
<meta name="image" content="https://etcanada.com/wp-content/uploads/2020/07/HSM-FEATURE.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="thumbnail" content="https://etcanada.com/wp-content/uploads/2020/07/HSM-FEATURE.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="dateCreated" content="2020-07-06T09:01">
<meta name="pubdate" content="2020-07-06T09:01">
<meta name="moddate" content="2020-07-06T09:07">
<meta name="news_keywords" content="Gay, High School Musical, Hocus Pocus, HSM, Kenny Ortega, LGBTQ, Lucas Grabeel, Pride, Ryan, Entertainment, Movies">
<title>&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217; | ETCanada.com</title>
<!-- OG Tags -->
<meta property="og:title" content="&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217;">
<meta property="og:url" content="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/">
<meta property="og:description" content="&quot;High School Musical&quot; director Kenny Ortega has finally confirmed that Ryan (portrayed by Lucas Grabeel) is gay. Ortega, who himself is gay, confirmed the news while speaking with Variety about the queer aesthetic that runs through his films, and now actor Lucas Grabeel, who played Ryan has voiced his own reaction. RELATED: Billy Porter ‘Excited’&hellip;">
<meta property="og:image" content="https://etcanada.com/wp-content/uploads/2020/07/HSM-FEATURE.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta property="og:type" content="article">
<meta property="og:site_name" content="ET Canada">

<!-- Twitter Tags -->
<meta name="twitter:title" content="&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217;">
<meta name="twitter:url" content="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/">
<meta name="twitter:description" content="&quot;High School Musical&quot; director Kenny Ortega has finally confirmed that Ryan (portrayed by Lucas Grabeel) is gay. Ortega, who himself is gay, confirmed the news while speaking with Variety about the queer aesthetic that runs through his films, and now actor Lucas Grabeel, who played Ryan has voiced his own reaction. RELATED: Billy Porter ‘Excited’&hellip;">
<meta name="twitter:image" content="https://etcanada.com/wp-content/uploads/2020/07/HSM-FEATURE.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="twitter:site" content="@ETCanada">
<meta name="twitter:card" content="summary_large_image">

<!-- FB Tags -->
<meta property="fb:app_id" content="508564806021134">
<meta property="fb:pages" content="163185517061777">

<!-- Article Tags -->
<meta property="article:section" content="Entertainment">
<meta property="article:published_time" content="2020-07-06T09:01">
<meta property="article:modified_time" content="2020-07-06T09:07">
<meta property="article:tag" content="Gay">
<meta property="article:tag" content="High School Musical">
<meta property="article:tag" content="Hocus Pocus">
<meta property="article:tag" content="HSM">
<meta property="article:tag" content="Kenny Ortega">
<meta property="article:tag" content="LGBTQ">
<meta property="article:tag" content="Lucas Grabeel">
<meta property="article:tag" content="Pride">
<meta property="article:tag" content="Ryan">
<meta property="article:tag" content="Entertainment">
<meta property="article:tag" content="Movies">
<meta property="article:publisher" content="https://www.facebook.com/ETCanada/">
		
		<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "WebSite",
			"url": "https:\/\/etcanada.com",
			"potentialAction": {
								"@type": "SearchAction",
								"target": "https:\/\/etcanada.com\/?s={search_term_string}",
								"query-input": "required name=search_term_string"
			}
		}
		</script>
		
				<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "\/\/connect.facebook.net\/en_US\/sdk.js#xfbml=1&appId=508564806021134&version=v2.6";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>
		<link rel="amphtml" href="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/amp/"><link rel="icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=32" sizes="32x32" />
<link rel="icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=180" />
<meta name="msapplication-TileImage" content="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=270" />
				<script>
    // Load the APS JavaScript Library
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // Initialize the Library
    apstag.init({
         pubID: '3311',
         adServer: 'googletag'
    });

  googletag.cmd.push(function() {
    var biddingSlots = [];
          var etcgptlb1Mapping = typeof( gpt_ad_slots["etc-gpt-lb1"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-lb1"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-lb1",
         slotName: "\/6872\/shaw.etcanada.com\/663253\/pride\/etc-gpt-lb1",
         sizes: etcgptlb1Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptlb1Mapping ) : [728,90]      });
          var etcgptbb1Mapping = typeof( gpt_ad_slots["etc-gpt-bb1"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-bb1"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-bb1",
         slotName: "\/6872\/shaw.etcanada.com\/663253\/pride\/etc-gpt-bb1",
         sizes: etcgptbb1Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptbb1Mapping ) : [[300,250],[300,600]]      });
          var etcgptbb2Mapping = typeof( gpt_ad_slots["etc-gpt-bb2"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-bb2"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-bb2",
         slotName: "\/6872\/shaw.etcanada.com\/663253\/pride\/etc-gpt-bb2",
         sizes: etcgptbb2Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptbb2Mapping ) : [300,250]      });
    
    apstag.fetchBids({
      slots: biddingSlots, 
      timeout: 1200
    }, function(bids) {
      // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration 
      googletag.cmd.push(function(){
        apstag.setDisplayBids();
        googletag.pubads().refresh();
      });
    });
  });
</script>
    	
    		<style>
		div.box-label,
		h4.kicker {
			color:#2397ff; 
					}
		h2.heading {
											}
		h2.heading span.accent {
			color:#0060b6; 
		}
		
		ul.content-list a:hover, ul.content-list a:hover .headline,
		.hoverable:hover > span, .hoverable:focus > span, .hoverable a:hover, .hoverable a:focus {
			color:#2397ff !important; 
		}
		.content-wrapper a, .article-wrapper a {
			color:#2397ff; 
		}
		div.load-more {
								}
		
		
	</style>
	
	    	
    			
		<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js"></script>

						<script type="text/javascript" src="https://assets.adobedtm.com/launch-EN6bb9ef052fe24388b9d1ae37a0dd4e00.min.js" async></script>
					
	</head>
	<body class="post-template-default single single-post postid-663253 single-format-standard">
		<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', "UA-43818396-1", 'auto');
	  ga('send', 'pageview');

	</script>
	
	<!-- LEADERBOARD -->
		<div class="ad-container" data-sticky-container >
		<section data-sticky data-sticky-on="small" data-margin-top="0" data-anchor="content" class="leaderboard sticky">	<div id="etc-gpt-lb1" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-lb1");
			});
		</script>
	</div>
	</section>	</div>
	
	<div class="nav-wrapper single-nav" data-sticky-container>
	<nav data-sticky data-sticky-on="small" data-anchor="content" data-margin-top="0" style="width:100%">
		<div class="top-bar">
			<div class="top-bar-title">
				<a href="https://etcanada.com/">
					<img class="logo" src="https://etcanada.com/wp-content/uploads/2019/08/etcanada-blue.png?w=90" alt="ET Canada"/>
				</a>
			</div>
			<div>
				<div class="top-bar-left">
					<div id="site-menu" class="menu-items" data-toggler=".active">
						<div class="menu-dropdown-wrapper">
							<div class="menu-toggle hoverable" data-toggle="site-menu">
								<span class="icon-menu"></span>
								<span class="icon-close"></span>
								<span class="heading"> SECTIONS</span>
							</div>
							<ul class="menu menu-dropdown hoverable">
								<li class="search">
									<form class="search-form" method="get" action="/">
										<input type="text" name="s" placeholder="SEARCH" value="" autocomplete="off">
										<input type="hidden" name="video-search" value="0">
										<button type="submit" class="hollow button icon-search"></button>
									</form>
								</li>
								<li id="menu-item-35" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li id="menu-item-37" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li id="menu-item-38" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li id="menu-item-42" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
								<li class="social">
									<div>
										<a class="icon-facebook" href="//facebook.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | facebook" data-track-value="facebook"></a><a class="icon-twitter" href="//twitter.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | twitter" data-track-value="twitter"></a><a class="icon-instagram" href="//instagram.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | instagram" data-track-value="instagram"></a><a class="icon-youtube" href="https://www.youtube.com/c/etcanadaofficial" data-track-name="social.exit" data-track-desc="exit to social channel | youtube" data-track-value="youtube"></a>									</div>
								</li>
									<li class="ad-choices">
										<a href="http://www.corusent.com/privacy-policy/#adchoices" target="_blank">
											<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/ad-choices.png"> <span>Ad Choices</span>
										</a>
									</li>
							</ul>
						</div>
						<div class="menu-links-wrapper hoverable">
							<ul id="menu-links" class="menu-links"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
</ul>						</div>
					</div>
					
																<div class="trending-items hoverable">
							<div class="box-label">TRENDING NOW</div>
							<ul>
								<li><a href="https://etcanada.com/news/664519/nick-cordero-dies-after-battle-with-covid-19/">Nick Cordero</a></li><li><a href="https://etcanada.com/news/664545/spaghetti-western-movie-composer-ennio-morricone-dead-at-91/">Ennio Morricone</a></li><li><a href="https://etcanada.com/news/664602/outlander-star-sam-heughan-is-the-fan-favourite-to-be-the-next-james-bond-according-to-new-poll/">James Bond</a></li><li><a href="https://etcanada.com/news/664513/tiffany-haddish-jokes-she-is-running-for-president-with-dave-chappelle-as-her-vp/">Tiffany Haddish </a></li><li><a href="https://etcanada.com/news/664554/machine-gun-kelly-mourns-the-death-of-his-dad-in-heartbreaking-post/">Machine Gun Kelly</a></li><li><a href="https://etcanada.com/news/664498/bts-nearly-ties-adeles-itunes-record/">BTS</a></li><li><a href="https://etcanada.com/tag/pride/">Pride</a></li><li><a href="https://etcanada.com/tag/royals/">Royals</a></li>							</ul>
						</div>
														</div>
				<div class="top-bar-right">
						<div class="ad-choices">
							<a href="http://www.corusent.com/privacy-policy/#adchoices" target="_blank">
								<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/ad-choices.png"> <span>Ad Choices</span>
							</a>
						</div>
					<form class="search-form" method="get" action="/">
						<input type="text" name="s" placeholder="Search" value="" autocomplete="off">
						<input type="hidden" name="video-search" value="0">
						<button type="submit" class="hollow button icon-search"></button>
					</form>
					<div class="social-icons hoverable">
													<a class="icon-facebook" href="//facebook.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | facebook" data-track-value="facebook"></a>
													<a class="icon-twitter" href="//twitter.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | twitter" data-track-value="twitter"></a>
													<a class="icon-instagram" href="//instagram.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | instagram" data-track-value="instagram"></a>
											</div>
				</div>
			</div>
							<div class="article-social">
					
<ul class="social-share" data-social-share-url="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/" data-social-share-title="&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217;">
	<li class="facebook" title="Share this on Facebook" data-social-share-provider="facebook">
		<a class="icon-facebook" target="_blank" data-track-rule="contentShare" data-track-name="content.share" data-track-desc="share on facebook" data-track-value="share|facebook" data-track-page="true" href="//www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F"></a>
	</li>
	<li class="twitter" title="Share this on Twitter" data-social-share-provider="twitter">
		<a class="icon-twitter" target="_blank" data-track-rule="contentShare" data-track-name="content.share" data-track-desc="share on twitter" data-track-value="share|twitter" data-track-page="true" href="//twitter.com/intent/tweet?text=%E2%80%98High%20School%20Musical%E2%80%99%20Actor%20Lucas%20Grabeel%20Doesn%E2%80%99t%20Know%20If%20He%E2%80%99d%20Play%20Ryan%20Today%3A%20%E2%80%98There%20Are%20So%20Many%20Amazingly%20Talented%20Gay%20Actors%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F"></a>
	</li>
	<li class="email" title="Email this page to a friend" data-social-share-provider="email">
		<a class="icon-email" target="_blank" data-track-rule="contentShare" data-track-name="content.share"  data-track-desc="share on email" data-track-value="share|email" data-track-page="true" href="mailto:?Subject=%E2%80%98High%20School%20Musical%E2%80%99%20Actor%20Lucas%20Grabeel%20Doesn%E2%80%99t%20Know%20If%20He%E2%80%99d%20Play%20Ryan%20Today%3A%20%E2%80%98There%20Are%20So%20Many%20Amazingly%20Talented%20Gay%20Actors%E2%80%99&#038;body=%E2%80%98High%20School%20Musical%E2%80%99%20Actor%20Lucas%20Grabeel%20Doesn%E2%80%99t%20Know%20If%20He%E2%80%99d%20Play%20Ryan%20Today%3A%20%E2%80%98There%20Are%20So%20Many%20Amazingly%20Talented%20Gay%20Actors%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F"></a>
	</li>
</ul>					<span class="icon-close"></span>
				</div>
						<div class="spacer"></div>
		</div>
	</nav>
</div>
	<div class="layout-wrapper">
		<main id="content">

	
<div class="column-wrapper">
	<div class="stream">
		<div class="article content-wrapper">
			
<h1>&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217;</h1> <!-- title -->

<p class="byline">
	By <span class="author-name">Shakiel Mahjouri</span>.<!-- Author byine -->
	<time>
		42 mins ago <!-- Published -->
	</time>
</p>

<!-- Social share buttons -->
<div class="sticky-social-wrapper" data-sticky-container>
	<div class="sticky-social" data-sticky data-sticky-on="xxlarge" data-anchor="content">
		
<ul class="social-share" data-social-share-url="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/" data-social-share-title="&#8216;High School Musical&#8217; Actor Lucas Grabeel Doesn&#8217;t Know If He&#8217;d Play Ryan Today: &#8216;There Are So Many Amazingly Talented Gay Actors&#8217;">
	<li class="facebook" title="Share this on Facebook" data-social-share-provider="facebook">
		<a class="icon-facebook" target="_blank" data-track-rule="contentShare" data-track-name="content.share" data-track-desc="share on facebook" data-track-value="share|facebook" data-track-page="true" href="//www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F"></a>
	</li>
	<li class="twitter" title="Share this on Twitter" data-social-share-provider="twitter">
		<a class="icon-twitter" target="_blank" data-track-rule="contentShare" data-track-name="content.share" data-track-desc="share on twitter" data-track-value="share|twitter" data-track-page="true" href="//twitter.com/intent/tweet?text=%E2%80%98High%20School%20Musical%E2%80%99%20Actor%20Lucas%20Grabeel%20Doesn%E2%80%99t%20Know%20If%20He%E2%80%99d%20Play%20Ryan%20Today%3A%20%E2%80%98There%20Are%20So%20Many%20Amazingly%20Talented%20Gay%20Actors%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F"></a>
	</li>
	<li class="email" title="Email this page to a friend" data-social-share-provider="email">
		<a class="icon-email" target="_blank" data-track-rule="contentShare" data-track-name="content.share"  data-track-desc="share on email" data-track-value="share|email" data-track-page="true" href="mailto:?Subject=%E2%80%98High%20School%20Musical%E2%80%99%20Actor%20Lucas%20Grabeel%20Doesn%E2%80%99t%20Know%20If%20He%E2%80%99d%20Play%20Ryan%20Today%3A%20%E2%80%98There%20Are%20So%20Many%20Amazingly%20Talented%20Gay%20Actors%E2%80%99&#038;body=%E2%80%98High%20School%20Musical%E2%80%99%20Actor%20Lucas%20Grabeel%20Doesn%E2%80%99t%20Know%20If%20He%E2%80%99d%20Play%20Ryan%20Today%3A%20%E2%80%98There%20Are%20So%20Many%20Amazingly%20Talented%20Gay%20Actors%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F663253%2Fhigh-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors%2F"></a>
	</li>
</ul>	</div>
</div>

<figure class="featured-image">
		<img 
		data-interchange="[https://etcanada.com/wp-content/uploads/2020/07/HSM-FEATURE.jpg?quality=80&amp;strip=all&amp;w=450&amp;h=300&amp;crop=1, small], [https://etcanada.com/wp-content/uploads/2020/07/HSM-FEATURE.jpg?quality=80&amp;strip=all&amp;w=720&amp;h=480&amp;crop=1, not-small]"
		src="https://etcanada.com/wp-content/uploads/2020/07/HSM-FEATURE.jpg?quality=80&#038;strip=all&#038;w=720&#038;h=480&#038;crop=1"
		alt="Lucas GrabeeL. Photo: YouTube/Disney"/>
	 
			<figcaption>
			<span>Lucas GrabeeL. Photo: YouTube/Disney</span>
					</figcaption>
	</figure>
<article>
	<!-- story content -->
	<p>&#8220;High School Musical&#8221; director Kenny Ortega has <em>finally</em> confirmed that Ryan (portrayed by Lucas Grabeel) is gay.</p>
<p>Ortega, who himself is gay, confirmed the news while speaking with <a href="https://variety.com/2020/film/news/director-kenny-ortega-pride-high-school-musical-1234694033/" target="_blank" rel="noopener noreferrer"><em>Variety</em></a> about the queer aesthetic that runs through his films, and now actor Lucas Grabeel, who played Ryan has voiced his own reaction.</p>
<p class="headline"><a href="https://etcanada.com/news/663046/billy-porter-excited-to-be-first-gay-man-on-the-cover-of-essence-magazine/">RELATED: Billy Porter ‘Excited’ To Be First Gay Man On Essence Cover</a></p>
<p>Speaking to <a href="https://www.tmz.com/2020/07/05/lucas-grabeel-high-school-musical-ryan-gay-character-role/" target="_blank" rel="noopener noreferrer"><em>TMZ</em></a>, Grabeel said, “There’s so many amazingly talented gay actors that could do it as well, so if &#8216;High School Musical&#8217; was made today – I don’t know if I would play Ryan.&#8221;</p>
<p>He explained, “I would love to, but the last thing I want to do is take an opportunity away from other people. As a straight white man, I know that even without trying, I have taken opportunities away from other people.&#8221;</p>
<p>In his interview with <em>Variety</em>, Ortega said, &#8220;I put a lot of who I am into my work. I mean, really all the way back from the earliest work that I’ve done, even as a choreographer in film and television,&#8221; he said. &#8220;I think, yeah, that it’s just there and whether it’s screaming at you, or whether it’s just sort of quietly there, it’s there.&#8221;</p>
<p>&#8220;The character of Ryan in &#8216;High School Musical&#8217;, Sharpay’s twin brother, we decided he’d probably going to come out in college,&#8221; the filmmaker continued. &#8220;It was less about coming out and just more about letting his true colours come forward.&#8221;</p>
<p>Ortega was not confident that Disney or the greater audience was prepared for an explicitly gay character; however, he was not deterred from moulding the character the way he wanted.</p>
<p>&#8220;I have to be honest with you. I didn’t think at the time — and Disney is the most progressive group of people I’ve ever worked with,&#8221; he said. &#8220;I was concerned because it was family and kids, that Disney might not be ready to cross that line and move into that territory yet.&#8221;</p>
<p>&#8220;So, I just took it upon myself to make choices that I felt that those who were watching would grab,&#8221; Ortega explained. &#8220;They would see it, they would feel it, they would know it and they would identify with it. And that is what happened.&#8221;</p>
<p><a href="https://etcanada.com/news/662321/andy-cohen-officiates-a-virtual-gay-wedding-patti-labelle-performs/">RELATED: Andy Cohen Officiates A Virtual Gay Wedding</a></p>
<p>Grabeel also recalled talking to Ortega about the character and the idea that Disney wasn&#8217;t &#8220;ready&#8221; for an openly gay character in the movie.</p>
<p>&#8220;I came up to Kenny one day and was like, ‘Hey, so can we talk about the character for a second? Ryan’s gay, right?’” he said. “He was like, ‘Well, I mean, it’s a touchy subject sometimes with children’s programming – I’m not sure if Disney is ready now for that kind of thing. I absolutely agree that he is and I think we have an opportunity here to showcase a real person.’”</p>
<p>He continued, “[Coming out] is something that a lot of kids go through and don’t often see portrayed on television. At that time it was either [the gay characters were] extremely flamboyant or very closeted and kind of shut off.</p>
<p>&#8220;We need to start educating everyone at the youngest age possible and that’s why it will fall into the hands of Disney who create so much great programming for the developing minds of our future country,” Grabeel added. “We in the film industry have a duty to educate as well as entertain.”</p>
			<section class="gallery top-story">
				<a href="https://etcanada.com/photos/655723/virtual-lgbtq-events-taking-place-for-pride-2020/">
					<figure>
							<img 
							data-interchange="[https://etcanada.com/wp-content/uploads/2020/05/22779955.jpg?quality=80&amp;strip=all&amp;w=450&amp;h=300&amp;crop=1, small], [https://etcanada.com/wp-content/uploads/2020/05/22779955.jpg?quality=80&amp;strip=all&amp;w=720&amp;h=480&amp;crop=1, not-small]"
							src="https://etcanada.com/wp-content/uploads/2020/05/22779955.jpg?quality=80&#038;strip=all&#038;w=720&#038;h=480&#038;crop=1"
							alt=""
							nopin="true" />

							<!-- Caption -->
							<figcaption>
								
								<!-- Teaser -->
								<div class="kicker">Click to View Gallery</div>
								  	
								<!-- Title -->	
								<h3 class="headline">Virtual LGBTQ+ Events Taking Place For Pride 2020 (June 25 To July 2)</h3>
								  
							</figcaption>

							<span class="icon icon-images"></span>
							<button class="next-btn slick-arrow icon-chevron_right"><span class="show-for-sr">Next Slide</span></button>
					</figure>
				</a>
			</section>
		

	<!-- story ad -->
	<section  class="story-ad">	<div id="etc-gpt-bb2" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-bb2");
			});
		</script>
	</div>
	</section></article>

<!-- article tags -->
	<aside class="story-tags">
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/gay/">Gay</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/high-school-musical/">High School Musical</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/hocus-pocus/">Hocus Pocus</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/hsm/">HSM</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/kenny-ortega/">Kenny Ortega</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/lgbtq/">LGBTQ</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/lucas-grabeel/">Lucas Grabeel</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/pride/">Pride</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/ryan/">Ryan</a><!--
			--></span>
			</aside>

<!-- newsletter signup -->
	<section class="newsletterSignup newsletterSignup--article">
		<a href="https://etcanada.com/newsletters-sign-up/" target="_blank">
			<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/newsletter/newsletter-large.jpg" alt="Get breaking news in your inbox" />
		</a>
	</section>
	
<!-- article related -->

<div class="OUTBRAIN" data-src="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/" data-widget-id="AR_2" data-ob-template="ETCanada" ></div>

<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script><section class="featured-story-list"><h2 class="heading">Related </h2><ul class="content-list related"><li>
	<a href="https://etcanada.com/news/664602/outlander-star-sam-heughan-is-the-fan-favourite-to-be-the-next-james-bond-according-to-new-poll/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2020/07/GettyImages-1206512436.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin">
					</div>
		<h3 class="headline">&#8216;Outlander&#8217; Star Sam Heughan Is The Fan Favourite To Be The Next James Bond, According To New Poll</h3>                    
	</a>
</li><li>
	<a href="https://etcanada.com/news/664517/bryce-dallas-howard-used-to-use-robert-pattinson-post-it-notes/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2020/07/GettyImages-117113543.jpg?quality=80&#038;strip=all&#038;crop=0px%2C32px%2C2357px%2C1573px&#038;resize=387%2C258" nopin="nopin">
					</div>
		<h3 class="headline">Bryce Dallas Howard Used To Use Robert Pattinson Post-It Notes</h3>                    
	</a>
</li><li>
	<a href="https://etcanada.com/news/664507/tom-cruise-other-cast-and-crew-to-skip-england-quarantine-to-resume-mission-impossible-7-filming/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2020/07/CP17159887.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin">
					</div>
		<h3 class="headline">Tom Cruise, Other Cast And Crew To Skip England Quarantine To Resume &#8216;Mission: Impossible 7&#8217; Filming</h3>                    
	</a>
</li></ul></section>



<!-- pinterest footer code for pinit buttons -->
<script async defer data-pin-hover="true" src="//assets.pinterest.com/js/pinit.js"></script>
			<!-- OUTBRAIN RELATED CONTENT -->

			<!-- COMMENTS -->
							<a name="respond"></a>
				<h2 class="heading">Comments </h2>				<div id="comments-container">
						<div class="fb-comments" data-href="https://etcanada.com/news/663253/high-school-musical-actor-lucas-grabeel-doesnt-know-if-hed-play-ryan-today-there-are-so-many-amazingly-talented-gay-actors/" data-numposts="5" data-colorscheme="light" data-width="100%" data-order-by="reverse_time" ></div>
					</div>
					</div>
	</div><!-- END: stream -->

	<aside class="wells">
		<section  class="sidebar-ad widget">	<div id="etc-gpt-bb1" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-bb1");
			});
		</script>
	</div>
	</section><section class="widget image-link">
		<div id="etc-gpt-band1" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band1");
			});
		</script>
	</div>
		<div id="etc-gpt-band2" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band2");
			});
		</script>
	</div>
		<div id="etc-gpt-band3" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band3");
			});
		</script>
	</div>
	</section>
<!-- Microsites --><section class="widget image-link">					<a href="https://etcanada.com/tag/pride/">
						<img src="https://etcanada.com/wp-content/uploads/2020/01/pride-340x150-1.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1"/>
					</a>
									<a href="https://etcanada.com/tag/royals/">
						<img src="https://etcanada.com/wp-content/uploads/2020/02/royals-brick-340x150-1.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1"/>
					</a>
									<a href="https://etcanada.com/tag/country-club/">
						<img src="https://etcanada.com/wp-content/uploads/2020/02/country-club-web-brick-340x150b.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1"/>
					</a>
				</section>		<section class="widget side-posts-widget">
			<h2 class="heading">Most <span class="accent">Popular </span>Stories </h2>	
			<ul class="content-list">		
			
			<li class="media-object">
	<div class="media-object-section img-section">
	  <div class="thumbnail ">
	    <a href="https://etcanada.com/news/664434/ringo-starr-reveals-the-beatles-turned-down-50-million-for-reunion-concert-because-the-opening-act-was-a-shark/">
	    
		    		    	<div class="box-label">
		    		1		    	</div>
		    		    
	      		      		<img src="https://etcanada.com/wp-content/uploads/2020/07/CP11445035.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;"/>
	      		
	    </a>
	  </div>
	</div>
	<div class="media-object-section">
	  <div class="excerpt">
	    <h4>
	    	<a href="https://etcanada.com/news/664434/ringo-starr-reveals-the-beatles-turned-down-50-million-for-reunion-concert-because-the-opening-act-was-a-shark/">
	    		Ringo Starr Reveals The Beatles Turned Down $50 Million For Reunion Concert Because The Opening Act Was A Shark	    	</a>
	    </h4>
	  </div>
	</div>
</li><li class="media-object">
	<div class="media-object-section img-section">
	  <div class="thumbnail ">
	    <a href="https://etcanada.com/news/664347/gavin-rossdale-admits-his-most-embarrassing-moment-was-the-crumbling-of-my-marriage-to-gwen-stefani/">
	    
		    		    	<div class="box-label">
		    		2		    	</div>
		    		    
	      		      		<img src="https://etcanada.com/wp-content/uploads/2020/07/CP16430420.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;"/>
	      		
	    </a>
	  </div>
	</div>
	<div class="media-object-section">
	  <div class="excerpt">
	    <h4>
	    	<a href="https://etcanada.com/news/664347/gavin-rossdale-admits-his-most-embarrassing-moment-was-the-crumbling-of-my-marriage-to-gwen-stefani/">
	    		Gavin Rossdale Admits His &#8216;Most Embarrassing Moment&#8217; Was &#8216;The Crumbling Of My Marriage&#8217; To Gwen Stefani	    	</a>
	    </h4>
	  </div>
	</div>
</li><li class="media-object">
	<div class="media-object-section img-section">
	  <div class="thumbnail ">
	    <a href="https://etcanada.com/news/664481/j-k-rowling-posts-new-series-of-tweets-about-the-trans-community/">
	    
		    		    	<div class="box-label">
		    		3		    	</div>
		    		    
	      		      		<img src="https://etcanada.com/wp-content/uploads/2020/07/CP15631689-1.jpg?quality=80&#038;strip=all&#038;crop=0px%2C23px%2C1950px%2C1306px&#038;resize=145%2C97" style="max-width:145px;"/>
	      		
	    </a>
	  </div>
	</div>
	<div class="media-object-section">
	  <div class="excerpt">
	    <h4>
	    	<a href="https://etcanada.com/news/664481/j-k-rowling-posts-new-series-of-tweets-about-the-trans-community/">
	    		J.K. Rowling Posts New Series Of Tweets About The Trans Community	    	</a>
	    </h4>
	  </div>
	</div>
</li><li class="media-object">
	<div class="media-object-section img-section">
	  <div class="thumbnail ">
	    <a href="https://etcanada.com/news/664498/bts-nearly-ties-adeles-itunes-record/">
	    
		    		    	<div class="box-label">
		    		4		    	</div>
		    		    
	      		      		<img src="https://etcanada.com/wp-content/uploads/2020/07/blackswan.png?w=145&#038;h=97&#038;crop=1" style="max-width:145px;"/>
	      		
	    </a>
	  </div>
	</div>
	<div class="media-object-section">
	  <div class="excerpt">
	    <h4>
	    	<a href="https://etcanada.com/news/664498/bts-nearly-ties-adeles-itunes-record/">
	    		BTS Beats Adele&#8217;s iTunes Record	    	</a>
	    </h4>
	  </div>
	</div>
</li><li class="media-object">
	<div class="media-object-section img-section">
	  <div class="thumbnail ">
	    <a href="https://etcanada.com/news/664540/jon-gosselin-explains-why-son-collin-didnt-join-him-for-fourth-of-july/">
	    
		    		    	<div class="box-label">
		    		5		    	</div>
		    		    
	      		      		<img src="https://etcanada.com/wp-content/uploads/2020/07/GettyImages-1183544794.jpg?quality=80&#038;strip=all&#038;crop=0px%2C27px%2C3712px%2C2484px&#038;resize=145%2C97" style="max-width:145px;"/>
	      		
	    </a>
	  </div>
	</div>
	<div class="media-object-section">
	  <div class="excerpt">
	    <h4>
	    	<a href="https://etcanada.com/news/664540/jon-gosselin-explains-why-son-collin-didnt-join-him-for-fourth-of-july/">
	    		Jon Gosselin Explains Why Son Collin Didn&#8217;t Join Him For Fourth Of July	    	</a>
	    </h4>
	  </div>
	</div>
</li>			</ul>
		</section>
		

<section class="widget side-posts-widget">
	<a href="https://etcanada.com/video/">
		<h2 class="heading">Latest <span class="accent">Videos </span></h2>	
	</a>

	<ul class="content-list">
					<li class="media-object">
			  <div class="media-object-section img-section">
			    <div class="thumbnail icon-play">
			      <a href="https://etcanada.com/video/c0889f1a-bf88-11ea-8e62-0242ac110004/prince-william-kate-middleton-visit-nhs-hospital/">
			        <img src="https://i1.wp.com/media.globaltv.com/videostatic/vms/m8jwrg1816-fkt9b9pj74/ETC070620PrinceWilliamKateMiddletonAfternoonTea.png?w=145&#038;h=97&#038;quality=60">
			      </a>
			    </div>
			  </div>
			  <div class="media-object-section">
			    <div class="excerpt">
			      <h4>
			      	<a href="https://etcanada.com/video/c0889f1a-bf88-11ea-8e62-0242ac110004/prince-william-kate-middleton-visit-nhs-hospital/">
			      		Prince William &amp; Kate Middleton Visit NHS Hospital  			      	</a>
			      </h4>
			    </div>
			  </div>
			</li>
					<li class="media-object">
			  <div class="media-object-section img-section">
			    <div class="thumbnail icon-play">
			      <a href="https://etcanada.com/video/f529eb0c-beed-11ea-bba4-0242ac110005/paul-reiser-loved-his-characters-hippie-look-in-the-kominsky-method/">
			        <img src="https://i1.wp.com/assets.vms.corusappservices.com/upload/ETC070520PaulReiserTalksKominskyMethodAPTN.png?w=145&#038;h=97&#038;quality=60">
			      </a>
			    </div>
			  </div>
			  <div class="media-object-section">
			    <div class="excerpt">
			      <h4>
			      	<a href="https://etcanada.com/video/f529eb0c-beed-11ea-bba4-0242ac110005/paul-reiser-loved-his-characters-hippie-look-in-the-kominsky-method/">
			      		Paul Reiser Loved His Character’s Hippie Look In ‘The Kominsky Method’			      	</a>
			      </h4>
			    </div>
			  </div>
			</li>
					<li class="media-object">
			  <div class="media-object-section img-section">
			    <div class="thumbnail icon-play">
			      <a href="https://etcanada.com/video/246d5904-beed-11ea-a644-0242ac110005/karma-brings-new-level-of-challenges-to-kids-competition-shows/">
			        <img src="https://i1.wp.com/assets.vms.corusappservices.com/upload/ETC070520MichelleKhareTalksKarmaAPTN.png?w=145&#038;h=97&#038;quality=60">
			      </a>
			    </div>
			  </div>
			  <div class="media-object-section">
			    <div class="excerpt">
			      <h4>
			      	<a href="https://etcanada.com/video/246d5904-beed-11ea-a644-0242ac110005/karma-brings-new-level-of-challenges-to-kids-competition-shows/">
			      		‘Karma’ Brings New Level Of Challenges To Kid’s Competition Shows			      	</a>
			      </h4>
			    </div>
			  </div>
			</li>
					<li class="media-object">
			  <div class="media-object-section img-section">
			    <div class="thumbnail icon-play">
			      <a href="https://etcanada.com/video/fbff23d0-bed3-11ea-80ac-0242ac110005/a-capitol-fourth-celebrates-40th-anniversary-with-star-studded-performances/">
			        <img src="https://i0.wp.com/assets.vms.corusappservices.com/upload/ETC070520ACapitolFourthConcertAPTN.png?w=145&#038;h=97&#038;quality=60">
			      </a>
			    </div>
			  </div>
			  <div class="media-object-section">
			    <div class="excerpt">
			      <h4>
			      	<a href="https://etcanada.com/video/fbff23d0-bed3-11ea-80ac-0242ac110005/a-capitol-fourth-celebrates-40th-anniversary-with-star-studded-performances/">
			      		‘A Capitol Fourth’ Celebrates 40th Anniversary With Star-Studded Performances 			      	</a>
			      </h4>
			    </div>
			  </div>
			</li>
					<li class="media-object">
			  <div class="media-object-section img-section">
			    <div class="thumbnail icon-play">
			      <a href="https://etcanada.com/video/bea788a2-be28-11ea-be7b-0242ac110003/athlete-a-producer-jennifer-sey-on-changing-gymnastics-culture/">
			        <img src="https://i0.wp.com/assets.vms.corusappservices.com/upload/ETC070420JenniferSeyTalksAthleteAAPTNYouTube.png?w=145&#038;h=97&#038;quality=60">
			      </a>
			    </div>
			  </div>
			  <div class="media-object-section">
			    <div class="excerpt">
			      <h4>
			      	<a href="https://etcanada.com/video/bea788a2-be28-11ea-be7b-0242ac110003/athlete-a-producer-jennifer-sey-on-changing-gymnastics-culture/">
			      		&#039;Athlete A&#039; Producer Jennifer Sey On Changing Gymnastics Culture			      	</a>
			      </h4>
			    </div>
			  </div>
			</li>
			</ul>
</section>

<section class="widget image-link">
	</section><section class="widget image-link">
	</section><section class="widget image-link">
	</section>		</aside>
</div><!-- END: column-wrapper -->


		</main>
	</div><!-- END: layout-wrapper -->
	
	<!-- Wallpaper Ad Call -->
	<script>
		function cwChangeWallpaperAd(url, hex) {
			if ( typeof (url) === 'string' ) {
				jQuery('body').css("background", hex + " url(" + url + ") no-repeat center 120px");
			}
		}
		function cwChangeWallpaperAdFixed( $url, $hex, $attachment ) {
			if ( typeof ( $url ) === 'string' ) {
				jQuery( 'body' ).css( 'background', $hex + ' url(' + $url + ') no-repeat' );
				if ( $attachment && $attachment === true ) {
					jQuery( 'body' ).css( 'background-attachment', 'fixed' ).css( 'background-position', 'center top' );
				} else {
					jQuery( 'body' ).css( 'background-position', 'center 120px' );
				}
			}
		}
		function cwChangeWallpaperAdScrollOption( $url, $hex, $attachment ) {
			if ( $attachment !== undefined && $attachment === true ) {
				cwChangeWallpaperAdFixed( $url, $hex, $attachment );
			} else {			
				cwChangeWallpaperAd( $url, $hex );
			}
		}
	</script>

	
		<div id="etc-gpt-wall" class="" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-wall");
			});
		</script>
	</div>
	
	<footer>
	<section class="showtimes">
		<div>
			<a class="global-logo" href="https://www.globaltv.com">
				<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/global.png" alt="Global TV" />
			</a>
			<a class="etc-logo" href="https://etcanada.com">
				<img src="https://etcanada.com/wp-content/uploads/2019/08/etcanada-blue.png?w=82" alt="ET Canada" />
			</a>
			<div class="info">
				<div class="date">WEEKNIGHTS</div>
				<div class="time">7:30 ET</div>
			</div>
		</div>
	</section>
	<nav>
		<ul class="menu">
			<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
			<li class="social">
				<div>
											<a class="icon-facebook" href="//facebook.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | facebook" data-track-value="facebook"></a>
											<a class="icon-twitter" href="//twitter.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | twitter" data-track-value="twitter"></a>
											<a class="icon-instagram" href="//instagram.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | instagram" data-track-value="instagram"></a>
											<a class="icon-youtube" href="https://www.youtube.com/c/etcanadaofficial" data-track-name="social.exit" data-track-desc="exit to social channel | youtube" data-track-value="youtube"></a>
									</div>
			</li>
		</ul>
	</nav>
	<section class="corporate-footer">
		<ul class="hoverable">
			<li><a href="/pages/about/">About Us</a></li>
			<li><a href="http://www.corusent.com/privacy-policy/" target="_blank">Privacy Policy</a></li>
			<li><a href="//www.shawmedia.ca/copyright.asp" target="_blank">Copyright</a></li>
			<li><a href="//www.corusent.com/media-centre/brands/" target="_blank">Corus Entertainment</a></li>
			<li><a href="//www.corusent.com/about/our-brands/" target="_blank">Advertise</a></li>
			<li><a href="http://www.corusent.com/terms-of-use/" target="_blank">Terms of Use</a></li>
			<li><a href="http://www.corusent.com/terms-and-conditions/" target="_blank">Advertising Standard Terms</a></li>
			<li><a href="/notifications/">Notifications</a></li>
			<li>Corus Television</li>
		</ul>

		<a class="corus-logo" href="//corusent.com">
			<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/corus.png" alt="Corus Entertainment" />
		</a>

		<div class="copyright"><span>&copy;</span> Corus Entertainment Inc., 2020 All rights reserved.</div>			
	</section>
</footer>

			<script src="https://static.freeskreen.com/ba/31/freeskreen.min.js"></script>
						<script type="text/javascript">
						var _sf_async_config={};
			_sf_async_config.uid = "56730";
			_sf_async_config.domain = "etcanada.com";
			_sf_async_config.useCanonical = "true";
			 _sf_async_config.authors = "Shakiel Mahjouri";
			_sf_async_config.sections = "Movies";
					(function(){
			        function loadChartbeat() {
					window._sf_endpt=(new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', "\/\/static.chartbeat.com\/js\/chartbeat.js" );
					document.body.appendChild(e);
				  }
				  var oldonload = window.onload;
				  window.onload = (typeof window.onload != 'function') ?
					 loadChartbeat : function() { try { oldonload(); } catch (e) { loadChartbeat(); throw e} loadChartbeat(); };
				})();
		</script>
<script>
var etc_story_processor_setting = {"frequency":"200"};
</script>
<script>
var etc_app_setting = {"is_tag_manage":"1"};
</script>
<script type='text/javascript' src='https://etcanada.com/_static/??-eJydkkFqxDAMRS9UxYQSmC5Kz6LYmokSR3YteUJuX8O0MN3V3Qh9ofeRhNyRwScxEnO20E7qdMEDyMCjYEC3qos8u2NBA5Zc7SkddpZh1Rf3V5drqhLQOAkoW2sLrPZU7TbUyH5rtZKqUnzIR+y2Cle4s/Icya2flco5fMsuJzIP1ThqN6XJM8ZuLCYMeyr9U6q1K52A4R9kKifkkjypptLFY879K7JsYAX9xnLro+8c2q/dQv41JYuPNTSitTRJ+0w/V/jY38fpbby8jtNlWr8AWJAl1w=='></script>
<script type='text/javascript' src='https://stats.wp.com/e-202028.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'177646860',post:'663253',tz:'-4',srv:'etcanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '177646860', '663253' ]);
</script>
		
		
			<script>
				var etcDataLayer = typeof( etcDataLayer ) !== 'undefined' ? etcDataLayer : {};
		
			etcDataLayer["sitesubsection"] = "articles";
			etcDataLayer["sitesubsection"] = "articles|high school musical actor lucas grabeel doesnt know if hed play ryan today there are so many amazingly talented gay actors";
			etcDataLayer["sitesubsection2"] = "articles|high school musical actor lucas grabeel doesnt know if hed play ryan today there are so many amazingly talented gay actors";
			etcDataLayer["sitesubsection3"] = "articles|high school musical actor lucas grabeel doesnt know if hed play ryan today there are so many amazingly talented gay actors";
			etcDataLayer["sitesubsection4"] = "articles|high school musical actor lucas grabeel doesnt know if hed play ryan today there are so many amazingly talented gay actors";
		etcDataLayer['sitesection'] = "articles";
	etcDataLayer['pagename'] = "articles|high school musical actor lucas grabeel doesnt know if hed play ryan today there are so many amazingly talented gay actors";
	etcDataLayer['contenttitle'] = document.title;
	etcDataLayer['referrer'] = document.referrer;
			etcDataLayer["server"] = "www.etcanada.com";
			etcDataLayer["sitename"] = "etcanada";
			etcDataLayer["contenttype"] = "article";
			etcDataLayer["contentid"] = "etc_663253";
			etcDataLayer["publishdate"] = "2020\/07\/06";
			etcDataLayer["tag"] = "gay,high-school-musical,hocus-pocus,hsm,kenny-ortega,lgbtq,lucas-grabeel,pride,ryan";
			etcDataLayer["category"] = "movies";
			etcDataLayer["hourofday"] = "9";
			etcDataLayer["dayofweek"] = "monday";
			etcDataLayer["weekdayweekend"] = "weekday";
			</script>
				<a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=etcanada.com" rel="generator nofollow" class="powered-by-wpcom"><img src="https://etcanada.com/wp-content/mu-plugins/vip-helpers/images/vip-powered-dark-small.png" width="187" height="26" alt="Powered by WordPress.com VIP" /></a><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"75660ba8f4","applicationID":"418684753","transactionName":"Z1BWZxdTWkAHVExRXF4adVARW1tdSURRVlRcUA==","queueTime":0,"applicationTime":165,"atts":"SxdBEV9JSR9EVhoCSE1I","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>