<!DOCTYPE html>
<html lang="en-US">
	<head><script type="text/javascript">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</script>
		<!-- prefetch -->
		<link rel='dns-prefetch' href='//metrics.corus.ca' />
		<link rel='dns-prefetch' href='//www.facebook.com' />
		<link rel='dns-prefetch' href='//cdn.krxd.net' />
		<link rel='dns-prefetch' href='//beacon.krxd.net' />
		<link rel='dns-prefetch' href='//widgets.outbrain.com' />
		<link rel='dns-prefetch' href='//ping.chartbeat.net' />
		
		<!-- preload resource -->
		<link rel="preload" as="script" href="//sdk.sharethrough.com/gc.js" >
					<link rel="preload" as="script" href="//static.chartbeat.com/js/chartbeat.js">	
						<link rel="preload" as="script" href="//fonts.smdg.ca/pzs6hjq.js" >
		<link rel="preload" as="style" href="//fonts.smdg.ca/k/c/pzs6hjq-d.css" >
		
					<link rel="preload" as="script" href="//widgets.outbrain.com/outbrain.js" >
				
			
					<link rel="preload" as="script" href="//assets.pinterest.com/js/pinit.js" >
		
			<link rel="manifest" href="/manifest.json">
			<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
			<script>
				var OneSignal = window.OneSignal || [];
				OneSignal.push(function() {
					OneSignal.init({
						appId: "f03e98ed-27f4-45d1-9642-8fdfd9a63005",
					});

					OneSignal.on( 'popoverShown', function() {
						// Onesignal should be the first focusable item on the page
						// Reference: https://documentation.onesignal.com/docs/web-push-sdk#slide-prompt-events
						var oneSignalDialog = document.querySelector( '#onesignal-slidedown-dialog' );
						if ( ! oneSignalDialog ) {
							return;
						}
						var cancelButton = document.querySelector( '#onesignal-slidedown-cancel-button' );
						var allowButton = document.querySelector( '#onesignal-slidedown-allow-button' );
						var description = document.createElement( 'div' );
						var descriptionText = document.createTextNode( "We'd like to show you notifications for the latest news, features and updates." );
						description.appendChild( descriptionText );
						description.classList.add( 'sr-only' );
						description.classList.add( 'one-signal-hidden-button' );
						description.setAttribute( 'id', 'one-signal-description-id' );
						oneSignalDialog.appendChild( description );
						oneSignalDialog.setAttribute( 'aria-describedby', 'one-signal-description-id' );
						oneSignalDialog.setAttribute( 'tabindex', 0 );
						oneSignalDialog.setAttribute( 'aria-modal', true );
						oneSignalDialog.setAttribute( 'role', 'alertdialog' );
						oneSignalDialog.setAttribute( 'aria-label', 'Onesignal notifications alert' );
						allowButton.focus();

						// Trap focus inside the popup buttons
						// User has to tab 'Allow' or 'no Thanks' buttons to proceed to the site
						cancelButton.addEventListener( 'keydown', function(event) {
							if ( ! event.shiftKey && event.keyCode === 9 ) {
								event.preventDefault();
								allowButton.focus();
							}
						} );

						allowButton.addEventListener( 'keydown', function(event) {
							if ( event.shiftKey && event.keyCode === 9 ) {
								event.preventDefault();
								cancelButton.focus();
							}
						} );
					});

					// When popup closes, focus should be places on 
					// first focusable item of the page - 'Skip to main contact' button
					OneSignal.on( 'popoverClosed', function() {
						var skipToMain = document.querySelector( '.skip-to-main' );
						if ( skipToMain ) {
							skipToMain.focus();
						}
					} );

					OneSignal.on('subscriptionChange', function (isSubscribed) {
						// Omniture tracking
						if ( isSubscribed ) {
							if ( typeof( OmnitureHelper ) !== 'undefined' ) {
								// Custom link tracking for notification subscription
								// To Do: Ask Phil to set up event in report suite to properly capture this data
								OmnitureHelper.trackLink( this, 'o', 'notification subscription' );
							}
						}
					});
				});
			</script>
		
		<meta name="google-site-verification" content="r0Dy4SR0u4Dh1nb6DA29xRZe3j_bgGMrTuXtB6gccuo" />
		<meta id="metaViewport" name="viewport" content="width=device-width, initial-scale=1.0">
		
<script async src="//js-sec.indexww.com/ht/p/183422-67482236234351.js"></script>
	<script type='text/javascript' async="async" src='//cdn.districtm.ca/merge/merge.v4.2.102566.js'></script>
			<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="x4SpOp2Us67I6MlQN2uFse9KXvwgu1d8_r5F2qkIbYc" />
<link rel='dns-prefetch' href='//fonts.smdg.ca' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Latest Entertainment News | Top Celebrity News, Hollywood Headlines &raquo; Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album Comments Feed" href="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/etcanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://etcanada.com/_static/??-eJytkN0OgjAMhV/I0YCJ4oXxWcqoMu3GpFsIb2/5ufNGEm+aND3fOW1hjMYFy7klASsCrZMEDff2Zdg1Aw4TSJqYCu9CoYIDKGH7kCgkSB155aTD0VAyFgO2CHedCjgVbehv2JyukSDsNNzi0GchXtu1/s3ILOAOO4xx1/FC70xsBIOsP5COKH1Z+Gwi54dT1ZNSRN3sUtRL4tbPyM1fy1NVnau6PFYfNVOftw==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script id='etc-ads-scipts-js-extra'>
var gpt_ad_list = {"etc-gpt-lb1":{"sizes":[728,90],"pos":"1","companion":true,"biddable":true,"sizes_text":"728x90"},"etc-gpt-bb1":{"sizes":[[300,250],[300,600]],"pos":"1","companion":true,"biddable":true,"sizes_text":"300x250,300x600"},"etc-gpt-bb2":{"sizes":[300,250],"pos":"2","biddable":true,"sizes_text":"300x250"},"etc-gpt-band1":{"sizes":[340,100],"pos":"1","sizes_text":"340x100"},"etc-gpt-band2":{"sizes":[340,100],"pos":"2","sizes_text":"340x100"},"etc-gpt-band3":{"sizes":[340,100],"pos":"3","sizes_text":"340x100"},"etc-gpt-wall":{"sizes":[1,1],"pos":"1","out":true,"sizes_text":"1x1"}};
var gpt_ad_settings = {"adpath":"\/6872\/shaw.etcanada.com\/788316\/music","targets":{"site":"etcanada","network":"shaw","page":"post","id":"788316","category":["music"],"tag":["barbra-streisand","music","willie-nelson"]},"amazon_bidding":"1","sizemaps":{"etc-gpt-lb1":{"728x0":"728x90","0x0":"320x50"}},"is_video_single":""};
</script>
<script type='text/javascript' src='https://etcanada.com/_static/??-eJyNjUsOwjAMRC+EGzVIwAZxFpOYfJS4IR+1cHq8YMEKVRp5ZjHPo9YCgU0alpqKoueg+vralANPsR3UvxLk4Cp2+i2bhTtxV91TFqR5XIE6GGS0qEoaLnBTBo0nwIibRLn7aNnHjO+F4R6sDezAUypU9+/LB+oG7KMA2ibMLV/nk9ZnfZmPOn4AbbxkWw=='></script>
<script src='//fonts.smdg.ca/pzs6hjq.js?ver=5.7.2' id='typekit-js'></script>
<script type='text/javascript' src='https://etcanada.com/wp-content/themes/shaw-et-canada/js/etc-watcher.min.js?m=1622728132g'></script>
<link rel="https://api.w.org/" href="https://etcanada.com/wp-json/" /><link rel="alternate" type="application/json" href="https://etcanada.com/wp-json/wp/v2/posts/788316" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://etcanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://etcanada.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel="canonical" href="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/" />
<link rel='shortlink' href='https://etcanada.com/?p=788316' />
<link rel="alternate" type="application/json+oembed" href="https://etcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://etcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F&#038;format=xml" />

        <script type="text/javascript">
			window.onerror = function( msg, url, line, col, error ) {
				var xhr = new XMLHttpRequest();
				var nonce = '45ab7c92fe';

				xhr.open( 'POST', 'https://etcanada.com/wp-admin/admin-ajax.php' );
				xhr.setRequestHeader( 'Content-Type', 'application/x-www-form-urlencoded' );
				xhr.onload = function () {
					var response,
                        reload = false;

					if ( 200 === xhr.status ) {
                        try {
                        	response = JSON.parse( xhr.response );

                        	reload = response.data.reload;
                        } catch ( e ) {
                        	reload = false;
                        }
                    }

					// Automatically reload the page if a deprecation caused an automatic downgrade, ensure visitors get the best possible experience.
					if ( reload ) {
						location.reload();
                    }
				};

				xhr.send( encodeURI( 'action=jquery-migrate-downgrade-version&_wpnonce=' + nonce + '&msg=' + msg ) );

				// Suppress error alerts in older browsers
				return true;
			}
        </script>

		<style type='text/css'>img#wpstats{display:none}</style>
		
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		
<!-- JSON+LD -->
<script type="application/ld+json">{"@context":"http:\/\/schema.org","thumbnailUrl":"https:\/\/etcanada.com\/wp-content\/uploads\/2021\/06\/streisand-nelson.jpg?quality=80&strip=all&w=720&h=480&crop=1","image":{"@type":"ImageObject","url":"https:\/\/etcanada.com\/wp-content\/uploads\/2021\/06\/streisand-nelson.jpg?quality=80&strip=all&w=720&h=480&crop=1","width":720,"height":480},"@type":"NewsArticle","mainEntityOfPage":"https:\/\/etcanada.com\/news\/788316\/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album\/","headline":"Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album","datePublished":"2021-06-04T12:13","author":{"@type":"Person","name":"Corey Atad"},"publisher":{"@type":"Organization","name":"ET Canada","logo":{"@type":"ImageObject","url":"https:\/\/etcanada.com\/wp-content\/themes\/shaw-et-canada\/img\/logos\/etcanada-dark-small.png","width":60,"height":60}}}</script>
<!-- Meta Tags -->
<meta name="title" content="Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album">
<meta name="author" content="Corey Atad">
<meta name="description" content="Barbra Streisand and Willie Nelson sound great together. On Friday, Streisand debuted a previously unreleased duet of the song “I’d Want It To Be You” with Nelson, to be included on her upcoming rarities album Release Me 2. RELATED: Barbra Streisand Updates &#039;You&#039;ll Never Walk Alone&#039; For Front-Line Workers The recording was intended for the&hellip;">
<meta name="keywords" content="Barbra Streisand, Music, Willie Nelson, Entertainment, Music">
<meta name="image" content="https://etcanada.com/wp-content/uploads/2021/06/streisand-nelson.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="thumbnail" content="https://etcanada.com/wp-content/uploads/2021/06/streisand-nelson.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="dateCreated" content="2021-06-04T12:13">
<meta name="pubdate" content="2021-06-04T12:13">
<meta name="news_keywords" content="Barbra Streisand, Music, Willie Nelson, Entertainment, Music">
<title>Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album | ETCanada.com</title>
<!-- OG Tags -->
<meta property="og:title" content="Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album">
<meta property="og:url" content="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/">
<meta property="og:description" content="Barbra Streisand and Willie Nelson sound great together. On Friday, Streisand debuted a previously unreleased duet of the song “I’d Want It To Be You” with Nelson, to be included on her upcoming rarities album Release Me 2. RELATED: Barbra Streisand Updates &#039;You&#039;ll Never Walk Alone&#039; For Front-Line Workers The recording was intended for the&hellip;">
<meta property="og:image" content="https://etcanada.com/wp-content/uploads/2021/06/streisand-nelson.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta property="og:type" content="article">
<meta property="og:site_name" content="ET Canada">

<!-- Twitter Tags -->
<meta name="twitter:title" content="Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album">
<meta name="twitter:url" content="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/">
<meta name="twitter:description" content="Barbra Streisand and Willie Nelson sound great together. On Friday, Streisand debuted a previously unreleased duet of the song “I’d Want It To Be You” with Nelson, to be included on her upcoming rarities album Release Me 2. RELATED: Barbra Streisand Updates &#039;You&#039;ll Never Walk Alone&#039; For Front-Line Workers The recording was intended for the&hellip;">
<meta name="twitter:image" content="https://etcanada.com/wp-content/uploads/2021/06/streisand-nelson.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="twitter:site" content="@ETCanada">
<meta name="twitter:card" content="summary_large_image">

<!-- FB Tags -->
<meta property="fb:app_id" content="508564806021134">
<meta property="fb:pages" content="163185517061777">

<!-- Article Tags -->
<meta property="article:section" content="Entertainment">
<meta property="article:published_time" content="2021-06-04T12:13">
<meta property="article:tag" content="Barbra Streisand">
<meta property="article:tag" content="Music">
<meta property="article:tag" content="Willie Nelson">
<meta property="article:tag" content="Entertainment">
<meta property="article:tag" content="Music">
<meta property="article:publisher" content="https://www.facebook.com/ETCanada/">
		
		<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "WebSite",
			"url": "https:\/\/etcanada.com",
			"potentialAction": {
								"@type": "SearchAction",
								"target": "https:\/\/etcanada.com\/?s={search_term_string}",
								"query-input": "required name=search_term_string"
			}
		}
		</script>
		
		<link rel="amphtml" href="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/amp/"><link rel="icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=32" sizes="32x32" />
<link rel="icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=180" />
<meta name="msapplication-TileImage" content="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=270" />
				<script>
    // Load the APS JavaScript Library
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // Initialize the Library
    apstag.init({
         pubID: '3311',
         adServer: 'googletag'
    });

  googletag.cmd.push(function() {
    var biddingSlots = [];
          var etcgptlb1Mapping = typeof( gpt_ad_slots["etc-gpt-lb1"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-lb1"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-lb1",
         slotName: "\/6872\/shaw.etcanada.com\/788316\/music\/etc-gpt-lb1",
         sizes: etcgptlb1Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptlb1Mapping ) : [728,90]      });
          var etcgptbb1Mapping = typeof( gpt_ad_slots["etc-gpt-bb1"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-bb1"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-bb1",
         slotName: "\/6872\/shaw.etcanada.com\/788316\/music\/etc-gpt-bb1",
         sizes: etcgptbb1Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptbb1Mapping ) : [[300,250],[300,600]]      });
          var etcgptbb2Mapping = typeof( gpt_ad_slots["etc-gpt-bb2"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-bb2"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-bb2",
         slotName: "\/6872\/shaw.etcanada.com\/788316\/music\/etc-gpt-bb2",
         sizes: etcgptbb2Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptbb2Mapping ) : [300,250]      });
    
    apstag.fetchBids({
      slots: biddingSlots, 
      timeout: 1200
    }, function(bids) {
      // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration 
      googletag.cmd.push(function(){
        apstag.setDisplayBids();
        googletag.pubads().refresh();
      });
    });
  });
</script>
    	
    		<style>
		div.box-label,
		.kicker {
			color:#2397ff; 
					}
		h2.heading {
											}
		h2.heading span.accent {
			color:#0060b6; 
		}
		
		ul.content-list a:hover, ul.content-list a:hover .headline,
		.hoverable:hover > span, .hoverable:focus > span, .hoverable a:hover, .hoverable a:focus {
			color:#0075df !important; 
		}
		.content-wrapper a, .article-wrapper a {
			color:#0075df; 
		}
		div.load-more {
								}
		
		
	</style>
	
	    	
    			
		<script type="text/javascript" async="async" src="//sdk.sharethrough.com/gc.js"></script>

						<script type="text/javascript" src="https://assets.adobedtm.com/launch-EN6bb9ef052fe24388b9d1ae37a0dd4e00.min.js" async></script>
					
	</head>
	<body class="post-template-default single single-post postid-788316 single-format-standard">
		<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', "UA-43818396-1", 'auto');
	  ga('send', 'pageview');

	</script>
	
				<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "\/\/connect.facebook.net\/en_US\/sdk.js#xfbml=1&appId=508564806021134&version=v2.6";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>
		
	<!-- LEADERBOARD -->
		<div class="ad-container" data-sticky-container >
		<section data-sticky data-sticky-on="small" data-margin-top="0" data-anchor="content" class="leaderboard sticky" aria-label="leaderboard section">	<div id="etc-gpt-lb1" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-lb1");
			});
		</script>
	</div>
	</section>	</div>
	
	<div id="header" class="nav-wrapper single-nav" data-sticky-container>
	<nav data-sticky data-sticky-on="small" data-anchor="content" data-margin-top="0" style="width:100%" aria-label="Main site navigation">
		<div class="top-bar">
			<a class="skip-to-main" href="#content">Skip to Main Content</a>
			<div class="top-bar-title">
				<a class="logo-link" href="https://etcanada.com/">
					<img class="logo" src="https://etcanada.com/wp-content/uploads/2019/08/etcanada-blue.png?w=90" alt="ET Canada"/>
				</a>
			</div>
			<div>
				<div class="top-bar-left">
					<div id="site-menu" class="menu-items" data-toggler=".active">
						<div class="menu-dropdown-wrapper" id="header-dropdown-toggle">
							<button class="menu-toggle hoverable" data-toggle="site-menu" data-track-name="dropdown.open" data-track-value="true" data-track-desc="dropdown menu toggle">
								<span class="icon-menu"><span class="sr-only">open</span></span>
								<span class="icon-close"><span class="sr-only">close</span></span>
								<span class="heading"> SECTIONS</span>
							</button>
							<ul class="menu menu-dropdown hoverable" id="header-dropdown-menu">
								<li class="search" id="header-dropdown-search">
									<form class="search-form" method="get" action="/">
										<label class="sr-only" for="search-input-mobile">Search site content</label>
										<input id="search-input-mobile" type="text" name="s" placeholder="SEARCH" value="" autocomplete="off">
										<input type="hidden" name="video-search" value="0">
										<button type="submit" class="hollow button icon-search">
											<span class="sr-only">Search</span>
										</button>
									</form>
								</li>
								<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
								<li class="social" id="header-dropdown-social">
									<div>
										<a class="icon-facebook" href="//facebook.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | facebook" data-track-value="facebook"><span class="sr-only">facebook</span></a><a class="icon-twitter" href="//twitter.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | twitter" data-track-value="twitter"><span class="sr-only">twitter</span></a><a class="icon-instagram" href="//instagram.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | instagram" data-track-value="instagram"><span class="sr-only">instagram</span></a><a class="icon-youtube" href="https://www.youtube.com/c/etcanadaofficial" data-track-name="social.exit" data-track-desc="exit to social channel | youtube" data-track-value="youtube"><span class="sr-only">youtube</span></a><a class="icon-linkedin" href="https://www.linkedin.com/company/et-canada/" data-track-name="social.exit" data-track-desc="exit to social channel | linkedin" data-track-value="linkedin"><span class="sr-only">linkedin</span></a>									</div>
								</li>
								<li class="ad-choices">
									<a href="http://www.corusent.com/privacy-policy/#adchoices" target="_blank" rel="noreferrer">
										<div class="sr-only">Ad Choices</div>
										<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/ad-choices.png" alt="">
										<span>Ad Choices</span>
									</a>
								</li>
							</ul>
						</div>
						<div class="menu-links-wrapper hoverable">
							<ul id="header-menu" class="menu-links"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
</ul>						</div>
					</div>
					
																<div class="trending-items hoverable" id="header-trending">
							<div class="box-label">TRENDING NOW</div>
							<ul>
								<li><a href="https://etcanada.com/news/788327/drake-and-3-year-old-son-adonis-take-in-lakers-game-in-los-angeles/">Drake</a></li><li><a href="https://etcanada.com/news/788158/kuwtk-kim-kardashian-breaks-down-over-marriage-troubles-with-kanye-west/">Kim Kardashian</a></li><li><a href="https://etcanada.com/news/788318/halsey-donates-100000-announces-universal-baby-shower-to-help-raise-money-for-struggling-soon-to-be-parents/">Halsey</a></li><li><a href="https://etcanada.com/news/788239/jeopardy-contestants-funny-facial-expressions-have-twitter-mesmerized/">&#039;Jeopardy!&#039;</a></li><li><a href="https://etcanada.com/news/788216/john-mayer-releases-new-music-video-for-last-train-home-featuring-maren-morris/">John Mayer</a></li><li><a href="https://etcanada.com/news/788176/greys-anatomy-closes-out-season-17-with-6-unanswered-questions/">&#039;Grey&#039;s Anatomy&#039;</a></li><li><a href="https://etcanada.com/tag/pride/">Pride</a></li><li><a href="https://etcanada.com/tag/royals/">Royals</a></li>							</ul>
						</div>
														</div>
				<div class="top-bar-right">
						<div class="ad-choices">
							<a href="http://www.corusent.com/privacy-policy/#adchoices" target="_blank" rel="noreferrer">
								<div class="sr-only">Ad Choices</div>
								<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/ad-choices.png" alt=""> <span>Ad Choices</span>
							</a>
						</div>
					<form class="search-form" method="get" action="/" id="header-search">
						<label class="sr-only" for="search-input-desktop">Search site content</label>
						<input id="search-input-desktop" type="text" name="s" placeholder="Search" value="" autocomplete="off">
						<input type="hidden" name="video-search" value="0">
						<button type="submit" class="hollow button icon-search">
							<span class="sr-only">Search</span>
						</button>
					</form>
					<div class="social-icons hoverable" id="header-social">
													<a class="icon-facebook" 
								href="//facebook.com/etcanada" 
								data-track-name="social.exit" 
								data-track-desc="exit to social channel | facebook" 
								data-track-value="facebook"
							>
								<span class="sr-only">ETCanada facebook</span>	
							</a>
													<a class="icon-twitter" 
								href="//twitter.com/etcanada" 
								data-track-name="social.exit" 
								data-track-desc="exit to social channel | twitter" 
								data-track-value="twitter"
							>
								<span class="sr-only">ETCanada twitter</span>	
							</a>
													<a class="icon-instagram" 
								href="//instagram.com/etcanada" 
								data-track-name="social.exit" 
								data-track-desc="exit to social channel | instagram" 
								data-track-value="instagram"
							>
								<span class="sr-only">ETCanada instagram</span>	
							</a>
											</div>
				</div>
			</div>
							<div class="article-social">
					
<ul class="social-share" data-social-share-url="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/" data-social-share-title="Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album">
	<li class="facebook" title="Share this on Facebook" data-social-share-provider="facebook">
		<a class="icon-facebook"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on facebook" 
			data-track-value="share|facebook" 
			data-track-page="true" 
			href="//www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F" 
		>
			<span class="sr-only">Click to share this on Facebook</span>
		</a>
	</li>
	<li class="twitter" title="Share this on Twitter" data-social-share-provider="twitter">
		<a class="icon-twitter"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on twitter" 
			data-track-value="share|twitter" 
			data-track-page="true" 
			href="//twitter.com/intent/tweet?text=Barbra%20Streisand%20Shares%20Previously%20Unreleased%20Willie%20Nelson%20Duet%20From%20Upcoming%20Rarities%20Album%20https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F" 
		>
			<span class="sr-only">Click to share this on Twitter</span>
		</a>
	</li>
	<li class="email" title="Email this page to a friend" data-social-share-provider="email">
		<a class="icon-email"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on email" 
			data-track-value="share|email" 
			data-track-page="true" 
			href="mailto:?Subject=Barbra%20Streisand%20Shares%20Previously%20Unreleased%20Willie%20Nelson%20Duet%20From%20Upcoming%20Rarities%20Album&#038;body=Barbra%20Streisand%20Shares%20Previously%20Unreleased%20Willie%20Nelson%20Duet%20From%20Upcoming%20Rarities%20Album%20https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F" 
		>
			<span class="sr-only">Click to share this via email</span>
		</a>
	</li>
</ul>
					<span class="icon-close"></span>
				</div>
						<div class="spacer"></div>
		</div>
	</nav>
</div>
	<div class="layout-wrapper">
		<main id="content">

	
<div class="column-wrapper">
	<div class="stream">
		<div class="article content-wrapper">
			
<h1>Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album</h1> <!-- title -->

<p class="byline">
	By <span class="author-name">Corey Atad</span>.<!-- Author byine -->
	<time>
		1 hour ago <!-- Published -->
	</time>
</p>

<!-- Social share buttons -->
<div class="sticky-social-wrapper" data-sticky-container id="article-social-share">
	<div class="sticky-social" data-sticky data-sticky-on="xxlarge" data-anchor="content">
		
<ul class="social-share" data-social-share-url="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/" data-social-share-title="Barbra Streisand Shares Previously Unreleased Willie Nelson Duet From Upcoming Rarities Album">
	<li class="facebook" title="Share this on Facebook" data-social-share-provider="facebook">
		<a class="icon-facebook"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on facebook" 
			data-track-value="share|facebook" 
			data-track-page="true" 
			href="//www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F" 
		>
			<span class="sr-only">Click to share this on Facebook</span>
		</a>
	</li>
	<li class="twitter" title="Share this on Twitter" data-social-share-provider="twitter">
		<a class="icon-twitter"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on twitter" 
			data-track-value="share|twitter" 
			data-track-page="true" 
			href="//twitter.com/intent/tweet?text=Barbra%20Streisand%20Shares%20Previously%20Unreleased%20Willie%20Nelson%20Duet%20From%20Upcoming%20Rarities%20Album%20https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F" 
		>
			<span class="sr-only">Click to share this on Twitter</span>
		</a>
	</li>
	<li class="email" title="Email this page to a friend" data-social-share-provider="email">
		<a class="icon-email"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on email" 
			data-track-value="share|email" 
			data-track-page="true" 
			href="mailto:?Subject=Barbra%20Streisand%20Shares%20Previously%20Unreleased%20Willie%20Nelson%20Duet%20From%20Upcoming%20Rarities%20Album&#038;body=Barbra%20Streisand%20Shares%20Previously%20Unreleased%20Willie%20Nelson%20Duet%20From%20Upcoming%20Rarities%20Album%20https%3A%2F%2Fetcanada.com%2Fnews%2F788316%2Fbarbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album%2F" 
		>
			<span class="sr-only">Click to share this via email</span>
		</a>
	</li>
</ul>
	</div>
</div>

	<figure class="featured-embed">
	<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='640' height='360' src='https://www.youtube.com/embed/o0dRs0kjbgs?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent' allowfullscreen='true' style='border:0;' sandbox='allow-scripts allow-same-origin allow-popups allow-presentation'></iframe></span></p>
 <!-- related embed -->
			</figure>

<article id="article-body" class="article-body">
	<!-- story content -->
	<p>Barbra Streisand and Willie Nelson sound great together.</p>
<p>On Friday, Streisand debuted a previously unreleased duet of the song “I’d Want It To Be You” with Nelson, to be included on her upcoming rarities album <i>Release Me 2</i>.</p>
<p><a href="https://etcanada.com/news/638490/barbra-streisand-updates-youll-never-walk-alone-for-frontline-workers/">RELATED: Barbra Streisand Updates &#8216;You&#8217;ll Never Walk Alone&#8217; For Front-Line Workers</a></p>
<p>The recording was intended for the singer&#8217;s 2014 album <em>Partners</em> but she instead used a version featuring Blake Shelton.</p>
<p>In the video released alongside the new release, archival photos take fans on a journey through Streisand and Nelson&#8217;s iconic careers.</p>
<p><em>Release Me 2</em>, which will be out Aug. 6, will feature 10 tracks that span her career, including &#8220;Rainbow Connection&#8221; (a duet with Kermit the Frog) and covers of Carole King&#8217;s &#8220;You Light Up My Life&#8221; and Randy Newman&#8217;s &#8220;Living Without You&#8221;.</p>
<p><a href="https://etcanada.com/news/771140/willie-nelson-wants-joe-biden-to-make-4-20-into-a-national-holiday/">RELATED: Willie Nelson Wants Joe Biden To Make 4/20 Into A National Holiday</a></p>
<p>“For me, the studio is a combination musical playground and laboratory… a private sanctuary, where the possibility of catching lightning in a bottle always exists,” Streisand writes in the liner notes.</p>
<p>“Whenever that kind of magic happens, it’s extremely satisfying. Sometimes though, when the arrangement doesn’t quite gel or the song no longer fits the tone of the album it was meant for, the tapes go into the vault for safekeeping,&#8221; she adds. &#8220;Working on this second volume of <i>Release Me</i> has been a lovely walk down memory lane… a chance to revisit, and in some cases, add a finishing instrumental touch to songs that still resonate for me in meaningful ways.”</p>
<p>The album is a followup to Streisand&#8217;s previous <em>Release Me</em>, which debuted in 2012.</p>
		<div class="flex-video widescreen">
  			<iframe class="etc-vid" 
  				width="692" 
  				height="389" 
  				src="https://etcanada.com/embed/1330963011787/?autoPlay=false" 
  				frameborder="0" 
  				allowfullscreen 
  				scrolling="no" 
  				title="Video: Barbra Streisand On Her New Song About Trump" 
  			></iframe>
		</div>
		

	<!-- story ad -->
	<section  class="story-ad" aria-label="story ad section">	<div id="etc-gpt-bb2" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-bb2");
			});
		</script>
	</div>
	</section></article>

<!-- article tags -->
	<aside id="article-tags" class="story-tags" aria-label="Article tags">
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/barbra-streisand/">Barbra Streisand</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/music/">Music</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/willie-nelson/">Willie Nelson</a><!--
			--></span>
			</aside>

<!-- newsletter signup -->
	<section id="article-newsletter-signup" class="newsletterSignup newsletterSignup--article" aria-label="Newsletter signup">
		<a href="https://etcanada.com/newsletters-sign-up/" target="_blank" rel="noreferrer" data-track-name data-track-value data-track-desc="newsletter signup">
			<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/newsletter/newsletter-large.jpg" alt="Get breaking news in your inbox" />
		</a>
	</section>
	
<!-- article related -->

<div class="OUTBRAIN" data-src="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/" data-widget-id="AR_2" data-ob-template="ETCanada" ></div>

<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script><section id="article-related-stories" class="featured-story-list" aria-label="Related stories section"><h2 class="heading">Related </h2><ul class="content-list related"><li>
	<a href="https://etcanada.com/news/788245/breland-and-keith-urban-team-up-again-on-energetic-new-track-throw-it-back/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2021/06/GENERIC-2.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin" alt="">
					</div>
		<h3 class="headline">Breland And Keith Urban Team Up Again On Energetic New Track &#8216;Throw It Back&#8217;</h3>                    
	</a>
</li><li>
	<a href="https://etcanada.com/news/788248/roddy-ricch-dives-into-80s-nostalgia-with-thriller-inspired-late-at-night-music-video/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2021/06/Roddy-Ricch.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin" alt="">
					</div>
		<h3 class="headline">Roddy Ricch Dives Into &#8217;80s Nostalgia With &#8216;Thriller&#8217;-Inspired &#8216;Late At Night&#8217; Music Video</h3>                    
	</a>
</li><li>
	<a href="https://etcanada.com/news/788249/kids-question-ed-sheeran-on-how-much-money-he-has-what-his-last-lie-was-more-in-cute-clip/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2021/03/GettyImages-1160891159.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin" alt="">
					</div>
		<h3 class="headline">Kids Question Ed Sheeran On How Much Money He Has, What His Last Lie Was &#038; More In Cute Clip</h3>                    
	</a>
</li></ul></section>



<!-- pinterest footer code for pinit buttons -->
<script async defer data-pin-hover="true" src="//assets.pinterest.com/js/pinit.js"></script>
			<!-- OUTBRAIN RELATED CONTENT -->

			<!-- COMMENTS -->
							<a name="respond"></a>
				<h2 class="heading">Comments </h2>				<div id="comments-container">
						<div class="fb-comments" data-href="https://etcanada.com/news/788316/barbra-streisand-shares-previously-unreleased-willie-nelson-duet-from-upcoming-rarities-album/" data-numposts="5" data-colorscheme="light" data-width="100%" data-order-by="reverse_time" ></div>
					</div>
					</div>
	</div><!-- END: stream -->

	<aside class="wells" aria-label="Sidebar">
		<section  class="sidebar-ad widget" aria-label="sidebar ad widget section">	<div id="etc-gpt-bb1" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-bb1");
			});
		</script>
	</div>
	</section><section class="widget image-link" aria-label="Sidebar ad section">
		<div id="etc-gpt-band1" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band1");
			});
		</script>
	</div>
		<div id="etc-gpt-band2" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band2");
			});
		</script>
	</div>
		<div id="etc-gpt-band3" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band3");
			});
		</script>
	</div>
	</section>
<!-- Microsites --><section class="widget image-link" aria-label="Sidebar image links" data-id="sidebar-image-link">					<a href="https://etcanada.com/tag/royals/">
						<span class="sr-only">Royals</span>
						<img src="https://etcanada.com/wp-content/uploads/2021/04/Royals-Brick-340x150-1.jpeg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1" alt="" />
					</a>
									<a href="https://etcanada.com/tag/pride/">
						<span class="sr-only">Pride</span>
						<img src="https://etcanada.com/wp-content/uploads/2020/01/pride-340x150-1.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1" alt="" />
					</a>
									<a href="https://etcanada.com/tag/country-club/">
						<span class="sr-only">Country Club</span>
						<img src="https://etcanada.com/wp-content/uploads/2020/02/country-club-web-brick-340x150b.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1" alt="" />
					</a>
				</section>		<section class="widget side-posts-widget" aria-label="Sidebar popular stories" id="sidebar-popular-posts">
			<h2 class="heading">Most <span class="accent">Popular </span>Stories </h2>	
			<ul class="content-list">		
			
			<li class="media-object">
	<a href="https://etcanada.com/news/787647/garth-brooks-gets-emotional-as-kelly-clarkson-belts-out-stunning-performance-of-the-dance-at-kennedy-center-honours/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					1				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2021/06/clarksongarth1.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					Garth Brooks Gets Emotional As Kelly Clarkson Belts Out Stunning Performance Of &#8216;The Dance&#8217; At Kennedy Center Honours				</div>
			</div>
		</div>
	</a>
</li><li class="media-object">
	<a href="https://etcanada.com/news/784597/steve-o-convinced-a-doctor-to-temporarily-paralyze-him-for-stunt/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					2				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2021/04/GettyImages-1185170804.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					Steve-O Convinced A Doctor To Temporarily Paralyze Him For Stunt				</div>
			</div>
		</div>
	</a>
</li><li class="media-object">
	<a href="https://etcanada.com/news/786855/john-krasinski-put-his-marriage-on-the-line-with-terrifying-stunt-involving-emily-blunt-in-a-quiet-place-part-2/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					3				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2021/06/GettyImages-1206118555.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					John Krasinski Put His Marriage &#8216;On The Line&#8217; With Terrifying Stunt Involving Emily Blunt In &#8216;A Quiet Place Part 2&#8217;				</div>
			</div>
		</div>
	</a>
</li><li class="media-object">
	<a href="https://etcanada.com/news/787258/simu-liu-describes-growing-increasingly-frustrated-during-his-time-on-kims-convenience-in-candid-facebook-post/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					4				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2021/06/CP2895820.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					Simu Liu Describes Growing &#8216;Increasingly Frustrated&#8217; During His Time On &#8216;Kim&#8217;s Convenience&#8217; In Candid Facebook Post				</div>
			</div>
		</div>
	</a>
</li>			</ul>
		</section>
		

<section class="widget side-posts-widget" aria-label="Sidebar latest videos" id="sidebar-latest-videos">
	<a class="heading-link" href="https://etcanada.com/video/">
		<h2 class="heading">Latest <span class="accent">Videos </span></h2>	
	</a>

	<ul class="content-list">
					<li class="media-object">
				<a href="https://etcanada.com/video/75eaf06c-c53f-11eb-a957-0242ac110008/stars-preview-2021-kennedy-center-honors/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i1.wp.com/assets.vms.corusappservices.com/upload/ETC060421KennedyCentreHonorsBTS.png?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Stars Preview 2021 Kennedy Center Honors	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/7a444a92-c539-11eb-a5ee-0242ac110008/the-beaches-talk-new-ep-future-lovers/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i1.wp.com/assets.vms.corusappservices.com/upload/ETC060321TheBeachesFutureLovers.png?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								The Beaches Talk New EP &#039;Future Lovers&#039;	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/GLOB0056425680000000/jun-03-2021/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i0.wp.com/media.globaltv.com/videostatic/vms/GlobalTV/GLOB0056425680000000/GLOB0056425680000011_1_thumbnail.jpeg?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Jun-03-2021	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/218e57ac-c4ae-11eb-9d23-0242ac110008/cardi-b-john-cena-preview-f9/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i1.wp.com/media.globaltv.com/videostatic/vms/0k23y13ruc-xjqtvs7w98/F9_Fast_and_Furious_9_EPK_SBs_Cardi_B.jpg?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Cardi B, John Cena Preview &#039;F9&#039;	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/4ef47fe8-c4ac-11eb-99ec-0242ac110008/chris-harrison-not-returning-as-host-of-bachelor-in-paradise/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i2.wp.com/media.globaltv.com/videostatic/vms/piejl1n82u-gqb2q14pet/ETC060321_Chris_Harrison_Not_Returning_To_Bachelor_In_Paradise_04.jpg?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Chris Harrison Not Returning As Host Of &#039;Bachelor In Paradise&#039;	
							</div>
						</div>
					</div>
			  	</a>
			</li>
			</ul>
</section>

<section class="widget image-link" aria-label="Sidebar link A">
	</section><section class="widget image-link" aria-label="Sidebar link B">
	</section><section class="widget image-link" aria-label="Sidebar link C">
	</section>		</aside>
</div><!-- END: column-wrapper -->


		</main>
	</div><!-- END: layout-wrapper -->
	
	<!-- Wallpaper Ad Call -->
	<script>
		function cwChangeWallpaperAd(url, hex) {
			if ( typeof (url) === 'string' ) {
				jQuery('body').css("background", hex + " url(" + url + ") no-repeat center 120px");
			}
		}
		function cwChangeWallpaperAdFixed( $url, $hex, $attachment ) {
			if ( typeof ( $url ) === 'string' ) {
				jQuery( 'body' ).css( 'background', $hex + ' url(' + $url + ') no-repeat' );
				if ( $attachment && $attachment === true ) {
					jQuery( 'body' ).css( 'background-attachment', 'fixed' ).css( 'background-position', 'center top' );
				} else {
					jQuery( 'body' ).css( 'background-position', 'center 120px' );
				}
			}
		}
		function cwChangeWallpaperAdScrollOption( $url, $hex, $attachment ) {
			if ( $attachment !== undefined && $attachment === true ) {
				cwChangeWallpaperAdFixed( $url, $hex, $attachment );
			} else {			
				cwChangeWallpaperAd( $url, $hex );
			}
		}
	</script>

	
		<div id="etc-gpt-wall" class="" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-wall");
			});
		</script>
	</div>
	
	<footer>
	<section id="footer-showtimes" class="showtimes" aria-label="Showtimes information">
		<div>
			<a class="global-logo" href="https://www.globaltv.com">
				<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/global.png" alt="Global TV" />
			</a>
			<a class="etc-logo" href="https://etcanada.com">
				<img src="https://etcanada.com/wp-content/uploads/2019/08/etcanada-blue.png?w=82" alt="ET Canada" />
			</a>
			<div class="info">
				<div class="date">WEEKNIGHTS</div>
				<div class="time">7:30 ET</div>
			</div>
		</div>
	</section>
	<nav aria-label="Footer navigation">
		<ul class="menu" id="footer-menu">
			<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
			<li class="social" id="footer-social">
				<div>
											<a class="icon-facebook" href="//facebook.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | facebook" data-track-value="facebook">
							<span class="sr-only">facebook</span>
						</a>
											<a class="icon-twitter" href="//twitter.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | twitter" data-track-value="twitter">
							<span class="sr-only">twitter</span>
						</a>
											<a class="icon-instagram" href="//instagram.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | instagram" data-track-value="instagram">
							<span class="sr-only">instagram</span>
						</a>
											<a class="icon-youtube" href="https://www.youtube.com/c/etcanadaofficial" data-track-name="social.exit" data-track-desc="exit to social channel | youtube" data-track-value="youtube">
							<span class="sr-only">youtube</span>
						</a>
											<a class="icon-linkedin" href="https://www.linkedin.com/company/et-canada/" data-track-name="social.exit" data-track-desc="exit to social channel | linkedin" data-track-value="linkedin">
							<span class="sr-only">linkedin</span>
						</a>
									</div>
			</li>
		</ul>
	</nav>
	<section id="footer-corporate" class="corporate-footer" aria-label="Corus corporate links">
		<ul class="hoverable">
			<li><a href="/pages/about/">About Us</a></li>
			<li><a href="http://www.corusent.com/privacy-policy/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Privacy Policy</a></li>
			<li><a href="https://www.shawmedia.ca/copyright.asp" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Copyright</a></li>
			<li><a href="https://www.corusent.com/media-centre/brands/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Corus Entertainment</a></li>
			<li><a href="https://www.corusent.com/advertising/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Advertise</a></li>
			<li><a href="https://www.corusent.com/terms-of-use/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Terms of Use</a></li>
			<li><a href="https://www.corusent.com/terms-and-conditions/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Advertising Standard Terms</a></li>
			<li><a href="/notifications/">Notifications</a></li>
			<li>Corus Television</li>
		</ul>

		<a class="corus-logo" href="https://www.corusent.com" data-track-name data-track-desc="corporate link clicked" target="_blank">
			<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/corus.png" alt="Corus Entertainment Homepage" />
		</a>

		<div class="copyright"><span>&copy;</span> Corus Entertainment Inc., 2021 All rights reserved.</div>			
	</section>
</footer>

			<script src="https://static.freeskreen.com/ba/31/freeskreen.min.js"></script>
						<script type="text/javascript">
						var _sf_async_config={};
			_sf_async_config.uid = "56730";
			_sf_async_config.domain = "etcanada.com";
			_sf_async_config.useCanonical = "true";
			 _sf_async_config.authors = "Corey Atad";
			_sf_async_config.sections = "Music";
					(function(){
			        function loadChartbeat() {
					window._sf_endpt=(new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', "\/\/static.chartbeat.com\/js\/chartbeat.js" );
					document.body.appendChild(e);
				  }
				  var oldonload = window.onload;
				  window.onload = (typeof window.onload != 'function') ?
					 loadChartbeat : function() { try { oldonload(); } catch (e) { loadChartbeat(); throw e} loadChartbeat(); };
				})();
		</script>
<script id='etc-story-processor-js-extra'>
var etc_story_processor_setting = {"frequency":"200"};
</script>
<script id='etc-app-js-extra'>
var etc_app_setting = {"is_tag_manage":"1"};
</script>
<script type='text/javascript' src='https://etcanada.com/_static/??-eJydkt1uwzAIhV9oxGomdbuZ9izEpg2J/2Zwo7z9XLWVcjnvBvkgvmNAmC2DTVEpqtGZAomRGTcgBYsRHZpFjOfJbDMqcMxVD88hcBwWeTN/dbmkGh0qpwjC2socix6y3Ybi2a4tV1IV8g/5iN1W7gI3Fp48meWnUtmHp+xyIrVQlb10U5Iso+/GfEIXUunvUrRtaQd0/yBT2SGXZEkklS4ec+4fkeMKWtCuHK999I1du7Wry31d3n9Fex+PJ/as+5HmaH11jWuFTVKY6LXD7/B1Oo/jx/h5eh+XX9b3POA='></script>
<script src='https://stats.wp.com/e-202122.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8',blog:'177646860',post:'788316',tz:'-4',srv:'etcanada.com'} ]);
	_stq.push([ 'clickTrackerInit', '177646860', '788316' ]);
</script>
		
		
			<script>
				var etcDataLayer = typeof( etcDataLayer ) !== 'undefined' ? etcDataLayer : {};
		
			etcDataLayer["sitesubsection"] = "articles";
			etcDataLayer["sitesubsection"] = "articles|barbra streisand shares previously unreleased willie nelson duet from upcoming rarities album";
			etcDataLayer["sitesubsection2"] = "articles|barbra streisand shares previously unreleased willie nelson duet from upcoming rarities album";
			etcDataLayer["sitesubsection3"] = "articles|barbra streisand shares previously unreleased willie nelson duet from upcoming rarities album";
			etcDataLayer["sitesubsection4"] = "articles|barbra streisand shares previously unreleased willie nelson duet from upcoming rarities album";
		etcDataLayer['sitesection'] = "articles";
	etcDataLayer['pagename'] = "articles|barbra streisand shares previously unreleased willie nelson duet from upcoming rarities album";
	etcDataLayer['contenttitle'] = document.title;
	etcDataLayer['referrer'] = document.referrer;
			etcDataLayer["server"] = "www.etcanada.com";
			etcDataLayer["sitename"] = "etcanada";
			etcDataLayer["contenttype"] = "article";
			etcDataLayer["contentid"] = "etc_788316";
			etcDataLayer["publishdate"] = "2021\/06\/04";
			etcDataLayer["tag"] = "barbra-streisand,music,willie-nelson";
			etcDataLayer["category"] = "music";
			etcDataLayer["hourofday"] = "13";
			etcDataLayer["dayofweek"] = "friday";
			etcDataLayer["weekdayweekend"] = "weekday";
			</script>
				<section aria-label="Wordpress copyright">
	<a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=etcanada.com" rel="generator nofollow" class="powered-by-wpcom"><img src="https://etcanada.com/wp-content/mu-plugins/vip-helpers/images/vip-powered-dark-small.png" width="187" height="26" alt="Powered by WordPress VIP" /></a>	</section>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"75660ba8f4","applicationID":"418684753","transactionName":"Z1BWZxdTWkAHVExRXF4adVARW1tdSURRVlRcUA==","queueTime":0,"applicationTime":229,"atts":"SxdBEV9JSR9EVhoCSE1I","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>