<!DOCTYPE html>
<html lang="en-US">
	<head>
		<!-- prefetch -->
		<link rel='dns-prefetch' href='//metrics.corus.ca' />
		<link rel='dns-prefetch' href='//www.facebook.com' />
		<link rel='dns-prefetch' href='//widgets.outbrain.com' />
		<link rel='dns-prefetch' href='//ping.chartbeat.net' />
		
		<!-- preload resource -->
		<link rel="preload" as="script" href="//sdk.sharethrough.com/gc.js" >
					<link rel="preload" as="script" href="//static.chartbeat.com/js/chartbeat.js">	
				<link rel="preload" as="script" href="//fonts.smdg.ca/pzs6hjq.js" >
		<link rel="preload" as="style" href="//fonts.smdg.ca/k/c/pzs6hjq-d.css" >
		
					<link rel="preload" as="script" href="//widgets.outbrain.com/outbrain.js" >
				
			
					<link rel="preload" as="script" href="//assets.pinterest.com/js/pinit.js" >
		
		<!-- PWA styling -->
		<link rel="stylesheet" media="(display:standalone)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/css/pwa/etc-pwa-style.css">

			<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script>
			<script>
				var OneSignal = window.OneSignal || [];
				OneSignal.push(function() {
					OneSignal.init({
						appId: "f03e98ed-27f4-45d1-9642-8fdfd9a63005",
					});

					OneSignal.on( 'popoverShown', function() {
						// Onesignal should be the first focusable item on the page
						// Reference: https://documentation.onesignal.com/docs/web-push-sdk#slide-prompt-events
						var oneSignalDialog = document.querySelector( '#onesignal-slidedown-dialog' );
						if ( ! oneSignalDialog ) {
							return;
						}
						var cancelButton = document.querySelector( '#onesignal-slidedown-cancel-button' );
						var allowButton = document.querySelector( '#onesignal-slidedown-allow-button' );
						var description = document.createElement( 'div' );
						var descriptionText = document.createTextNode( "We'd like to show you notifications for the latest news, features and updates." );
						description.appendChild( descriptionText );
						description.classList.add( 'sr-only' );
						description.classList.add( 'one-signal-hidden-button' );
						description.setAttribute( 'id', 'one-signal-description-id' );
						oneSignalDialog.appendChild( description );
						oneSignalDialog.setAttribute( 'aria-describedby', 'one-signal-description-id' );
						oneSignalDialog.setAttribute( 'tabindex', 0 );
						oneSignalDialog.setAttribute( 'aria-modal', true );
						oneSignalDialog.setAttribute( 'role', 'alertdialog' );
						oneSignalDialog.setAttribute( 'aria-label', 'Onesignal notifications alert' );
						allowButton.focus();

						// Trap focus inside the popup buttons
						// User has to tab 'Allow' or 'no Thanks' buttons to proceed to the site
						cancelButton.addEventListener( 'keydown', function(event) {
							if ( ! event.shiftKey && event.keyCode === 9 ) {
								event.preventDefault();
								allowButton.focus();
							}
						} );

						allowButton.addEventListener( 'keydown', function(event) {
							if ( event.shiftKey && event.keyCode === 9 ) {
								event.preventDefault();
								cancelButton.focus();
							}
						} );
					});

					// When popup closes, focus should be places on 
					// first focusable item of the page - 'Skip to main contact' button
					OneSignal.on( 'popoverClosed', function() {
						var skipToMain = document.querySelector( '.skip-to-main' );
						if ( skipToMain ) {
							skipToMain.focus();
						}
					} );

					OneSignal.on('subscriptionChange', function (isSubscribed) {
						// Omniture tracking
						if ( isSubscribed ) {
							if ( typeof( OmnitureHelper ) !== 'undefined' ) {
								// Custom link tracking for notification subscription
								// To Do: Ask Phil to set up event in report suite to properly capture this data
								OmnitureHelper.trackLink( this, 'o', 'notification subscription' );
							}
						}
					});
				});
			</script>
		
		<meta name="google-site-verification" content="hKfNqKoDUEKkxbFmEYi3NsGNlMooZ9oJQO_AAiZe0Mw" />
		<meta id="metaViewport" name="viewport" content="width=device-width, initial-scale=1.0">
		
		<!-- IX wrapper for bidding -->
		<script async src="//js-sec.indexww.com/ht/p/183422-67482236234351.js"></script>

		<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="x4SpOp2Us67I6MlQN2uFse9KXvwgu1d8_r5F2qkIbYc" />
<link rel='dns-prefetch' href='//fonts.smdg.ca' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="ET Canada &raquo; Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217; Comments Feed" href="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/etcanada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style id='regular-critical-css-0' type='text/css'>

</style>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://etcanada.com/_static/??-eJyNy0sKgDAMRdENWUMp6EhcSz9BomktTUW6e50IOnN4ee/AmRUlz0dAAS8CgaSC491viskVWxpIbYx9pNTfhw7eYhWIGMgiY8RUP5HZNiyKcbG+/eP39u4HzXHSwzAao43WF4ePQaE=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://etcanada.com/_static/??-eJytkNEKwjAMRX/IGhTs9EH8lthFWsy66s0Y+/tV+wEq+BJIcu6BhObiwphNspFFGQSEyLMTc4Ez90y3ugWlChFsUdkGYEMfY5UiTVeCpnCvw+c4QbS1rf5N5N7BH3Rcypd0Ox7ymEQdOKP9AFHEXorLcN553x26/enoV55ueoE=' type='text/css' media='all' />
<link rel='stylesheet' id='critical-mobile-css'  href='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/css/critical-mobile.css?ver=SlSknGpsWIQ71WmuJUtTwruP%2Byw%3D' media='(min-width: 498px)' />
<link rel='stylesheet' id='critical-tablet-portrait-css'  href='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/css/critical-tablet-portrait.css?ver=NHeL8MzJPAkEGkqGTiSknnimWYE%3D' media='(min-width: 768px)' />
<link rel='stylesheet' id='critical-tablet-landscape-css'  href='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/css/critical-tablet-landscape.css?ver=ZnSddyzMIoPjBGWlh%2F%2B0szfgtoQ%3D' media='(min-width: 1024px)' />
<link rel='stylesheet' id='critical-desktop-css'  href='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/css/critical-desktop.css?ver=hWf%2BaRRTtDWl5PMzNS%2Fx8SPkwOs%3D' media='(min-width: 1312px)' />
<link rel='stylesheet' id='all-css-10' href='https://etcanada.com/wp-content/mu-plugins/jetpack-11.4/css/jetpack.css?m=1667314748g' type='text/css' media='all' />
<script id='etc-ads-scipts-js-extra'>
var gpt_ad_list = {"etc-gpt-lb1":{"sizes":[728,90],"pos":"1","companion":true,"biddable":true,"sizes_text":"728x90"},"etc-gpt-bb1":{"sizes":[[300,250],[300,600]],"pos":"1","companion":true,"biddable":true,"sizes_text":"300x250,300x600"},"etc-gpt-bb2":{"sizes":[300,250],"pos":"2","biddable":true,"sizes_text":"300x250"},"etc-gpt-band1":{"sizes":[340,100],"pos":"1","sizes_text":"340x100"},"etc-gpt-band2":{"sizes":[340,100],"pos":"2","sizes_text":"340x100"},"etc-gpt-band3":{"sizes":[340,100],"pos":"3","sizes_text":"340x100"},"etc-gpt-wall":{"sizes":[1,1],"pos":"1","out":true,"sizes_text":"1x1"}};
var gpt_ad_settings = {"adpath":"\/6872\/shaw.etcanada.com\/942064\/music","targets":{"site":"etcanada","network":"shaw","page":"post","id":"942064","category":["celebs","music"],"tag":["dolly-parton","music","rock-and-roll-hall-of-fame"]},"amazon_bidding":"1","sizemaps":{"etc-gpt-lb1":{"728x0":"728x90","0x0":"320x50"}},"is_video_single":""};
</script>
<script type="text/javascript" src="https://etcanada.com/_static/??-eJyNjTsOAjEMRC+ENwKJLBSIs5jE5KPEG/LRAqfHBQUVWmnkmWKeR60FAps0LDUVRY9B9fW1KQeeYtupfyXIwVXs9Fs2C3firrqnLEjzuAJ1MMhoUZU0XOCmDBpPgBGfEuVuo2UfM74XhluwNrADT6lQ3b4vH6gbsPcCaJsw13zZaz0f58P5pOMHbjFkcg==" ></script><script src='//fonts.smdg.ca/pzs6hjq.js?ver=6.0.3' id='typekit-js'></script>
<script type="text/javascript" src="https://etcanada.com/wp-content/themes/shaw-et-canada/js/etc-watcher.min.js?m=1667572986g" ></script><script defer="defer" src='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/js/utils~main.bundle.js?ver=oYz8HrVE2Vo214UaUZhcQ4%2Bl7Zg%3D' id='utils~main-js'></script>
<script defer="defer" src='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/js/vendor~main.bundle.js?ver=SKNxj%2B6e40o8CQZBXwWcYR%2BdNZA%3D' id='vendor~main-js'></script>
<script id='etc-main-js-extra'>
var etc_settings = {"template_type":"regular","page_type":"post"};
</script>
<script defer="defer" src='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/js/main.bundle.js?ver=1afEk0YIYo%2Fn4Iehlpa41QHp9ZI%3D' id='etc-main-js'></script>
<script defer="defer" src='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/js/vendor~styles.bundle.js?ver=Ea1FEOfpzvj0BoXnTwiSperpx34%3D' id='vendor~styles-js'></script>
<script defer="defer" src='https://etcanada.com/wp-content/themes/shaw-et-canada/assets/dist/js/styles.bundle.js?ver=LhbjDQufyWTRaj%2BQS4dSDNtTfb4%3D' id='etc-styles-js'></script>
<link rel="https://api.w.org/" href="https://etcanada.com/wp-json/" /><link rel="alternate" type="application/json" href="https://etcanada.com/wp-json/wp/v2/posts/942064" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://etcanada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://etcanada.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.3" />
<link rel="canonical" href="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/" />
<link rel='shortlink' href='https://etcanada.com/?p=942064' />
<link rel="alternate" type="application/json+oembed" href="https://etcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://etcanada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F&#038;format=xml" />
<style>img#wpstats{display:none}</style>
	
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
				<link rel="manifest" href="https://etcanada.com/wp-json/wp/v2/web-app-manifest">
		<meta name="theme-color" content="#0060b6">
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="mobile-web-app-capable" content="yes">
		<meta name="apple-touch-fullscreen" content="YES">
							<link rel="apple-touch-startup-image" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=192">
		
				<meta name="apple-mobile-web-app-title" content="ET Canada">
		<meta name="application-name" content="ET Canada">
			<!-- iPhone 12 mini, 11 pro, X, Xs (1125px x 2436px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 375px) and (device-height: 812px) and (-webkit-device-pixel-ratio: 3)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1125x2436.png">
	<!-- iPhone 8, 7, 6s, 6 (750px x 1334px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-750x1334.png">
	<!-- iPhone 8 Plus, 7 Plus, 6s Plus, 6 Plus (1080px x 1920px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 414px) and (device-height: 736px) and (-webkit-device-pixel-ratio: 3)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1080x1920.png">
	<!-- iPhone 5 (640px x 1136px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-640x1136.png">
	<!-- iPad Pro 9.7", mini 7.9", Air 9.7", 9.7" (1536px x 2048px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 768px) and (device-height: 1024px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1536x2048.png">
	<!-- iPad Pro 10.5" (1668px x 2224px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 834px) and (device-height: 1112px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1668x2224.png">
	<!-- iPad Pro 12.9" (2048px x 2732px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 1024px) and (device-height: 1366px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-2048x2732.png">
	<!-- iPad Pro 11", Pro 10.5" (1668px x 2388px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 834px) and (device-height: 1194px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1668x2388.png">
	<!-- iPad 10.2" (1620px x 2160px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 810px) and (device-height: 1080px) and (-webkit-device-pixel-ratio: 1)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1620x2160.png">
	<!-- iPhone 12 Pro Max (1284px x 2778px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 428px) and (device-height: 926px) and (-webkit-device-pixel-ratio: 3)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1284x2778.png">
	<!-- iPhone 12 Pro, 12 (1170px x 2532px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 390px) and (device-height: 844px) and (-webkit-device-pixel-ratio: 3)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1170x2532.png">
	<!-- iPhone 11 Pro Max, XS Max (1248px x 2688px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 3)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-1248x2688.png">
	<!-- iPhone 11, XR (828px x 1792px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-828x1792.png">
	<!-- iPhone 4" SE, iPod touch (640px x 1136px) -->
	<link rel="apple-touch-startup-image" media="(device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2)" href="https://etcanada.com/wp-content/themes/shaw-et-canada/img/pwa/ios/launch-640x1136.png">
	
<!-- JSON+LD -->
<script type="application/ld+json">{"@context":"http:\/\/schema.org","thumbnailUrl":"https:\/\/etcanada.com\/wp-content\/uploads\/2022\/11\/GettyImages-1439411083.jpg?quality=80&strip=all&w=720&h=480&crop=1","image":{"@type":"ImageObject","url":"https:\/\/etcanada.com\/wp-content\/uploads\/2022\/11\/GettyImages-1439411083.jpg?quality=80&strip=all&w=720&h=480&crop=1","width":720,"height":480},"@type":"NewsArticle","mainEntityOfPage":"https:\/\/etcanada.com\/news\/942064\/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now\/","headline":"Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217;","datePublished":"2022-11-06T12:00","dateModified":"2022-11-06T12:02","author":{"@type":"Person","name":"Brent Furdyk"},"publisher":{"@type":"Organization","name":"ET Canada","logo":{"@type":"ImageObject","url":"https:\/\/etcanada.com\/wp-content\/themes\/shaw-et-canada\/img\/logos\/etcanada-dark-small.png","width":60,"height":60}}}</script>
<!-- Meta Tags -->
<meta name="title" content="Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217;">
<meta name="author" content="Brent Furdyk">
<meta name="description" content="Dolly Parton was inducted into the Rock and Roll Hall of Fame on Saturday night, concluding a journey in which she initially attempted to withdraw from consideration before subsequently agreeing to the honour. Introduced by Pink, Parton delivered a rousing speech that served as a keen reminder of why the legendary country music singer and&hellip;">
<meta name="keywords" content="Dolly Parton, Music, Rock and Roll Hall of Fame, Entertainment, Celebs, Music">
<meta name="image" content="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1439411083.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="thumbnail" content="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1439411083.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="dateCreated" content="2022-11-06T12:00">
<meta name="pubdate" content="2022-11-06T12:00">
<meta name="moddate" content="2022-11-06T12:02">
<meta name="news_keywords" content="Dolly Parton, Music, Rock and Roll Hall of Fame, Entertainment, Celebs, Music">
<title>Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217; | ETCanada.com</title>
<!-- OG Tags -->
<meta property="og:title" content="Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217;">
<meta property="og:url" content="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/">
<meta property="og:description" content="Dolly Parton was inducted into the Rock and Roll Hall of Fame on Saturday night, concluding a journey in which she initially attempted to withdraw from consideration before subsequently agreeing to the honour. Introduced by Pink, Parton delivered a rousing speech that served as a keen reminder of why the legendary country music singer and&hellip;">
<meta property="og:image" content="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1439411083.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta property="og:type" content="article">
<meta property="og:site_name" content="ET Canada">

<!-- Twitter Tags -->
<meta name="twitter:title" content="Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217;">
<meta name="twitter:url" content="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/">
<meta name="twitter:description" content="Dolly Parton was inducted into the Rock and Roll Hall of Fame on Saturday night, concluding a journey in which she initially attempted to withdraw from consideration before subsequently agreeing to the honour. Introduced by Pink, Parton delivered a rousing speech that served as a keen reminder of why the legendary country music singer and&hellip;">
<meta name="twitter:image" content="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1439411083.jpg?quality=80&strip=all&w=720&h=480&crop=1">
<meta name="twitter:site" content="@ETCanada">
<meta name="twitter:card" content="summary_large_image">

<!-- FB Tags -->
<meta property="fb:app_id" content="508564806021134">
<meta property="fb:pages" content="163185517061777">

<!-- Article Tags -->
<meta property="article:section" content="Entertainment">
<meta property="article:published_time" content="2022-11-06T12:00">
<meta property="article:modified_time" content="2022-11-06T12:02">
<meta property="article:tag" content="Dolly Parton">
<meta property="article:tag" content="Music">
<meta property="article:tag" content="Rock and Roll Hall of Fame">
<meta property="article:tag" content="Entertainment">
<meta property="article:tag" content="Celebs">
<meta property="article:tag" content="Music">
<meta property="article:publisher" content="https://www.facebook.com/ETCanada/">
		
		<script type="application/ld+json">
		{
			"@context": "http://schema.org",
			"@type": "WebSite",
			"url": "https:\/\/etcanada.com",
			"potentialAction": {
								"@type": "SearchAction",
								"target": "https:\/\/etcanada.com\/?s={search_term_string}",
								"query-input": "required name=search_term_string"
			}
		}
		</script>
		
					<script>
				!function(n,e,i){if(!n){n=n||{},window.permutive=n,n.q=[],n.config=i||{},n.config.apiKey=e,n.config.environment=n.config.environment||"production";for(var o=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],r=0;r<o.length;r++){var t=o[r];n[t]=function(e){return function(){var i=Array.prototype.slice.call(arguments,0);n.q.push({functionName:e,arguments:i})}}(t)}}}(window.permutive,"2e14a473-6c86-4a13-b06d-59143665c372",{});
											permutive.addon('web', { "page": {"content":{"name":"Dolly Parton Inducted Into Rock & Roll Hall Of Fame: 'I'm A Rock Star Now!'","type":"article","keywords":["dolly-parton","music","rock-and-roll-hall-of-fame"],"sections":["articles","celebs","music"]},"user":{"client":"web"}} } )
								</script>
			<script async src="https://f7e98148-cb09-4cf1-9b9f-b5aee3465d6e.edge.permutive.app/f7e98148-cb09-4cf1-9b9f-b5aee3465d6e-web.js"></script>
		<link rel="amphtml" href="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/amp/"><link rel="icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=32" sizes="32x32" />
<link rel="icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=180" />
<meta name="msapplication-TileImage" content="https://etcanada.com/wp-content/uploads/2020/06/cropped-etcanada-blue.png?w=270" />
				<script>
    // Load the APS JavaScript Library
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // Initialize the Library
    apstag.init({
         pubID: '3311',
         adServer: 'googletag'
    });

  googletag.cmd.push(function() {
    var biddingSlots = [];
          var etcgptlb1Mapping = typeof( gpt_ad_slots["etc-gpt-lb1"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-lb1"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-lb1",
         slotName: "\/6872\/shaw.etcanada.com\/942064\/music\/etc-gpt-lb1",
         sizes: etcgptlb1Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptlb1Mapping ) : [728,90]      });
          var etcgptbb1Mapping = typeof( gpt_ad_slots["etc-gpt-bb1"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-bb1"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-bb1",
         slotName: "\/6872\/shaw.etcanada.com\/942064\/music\/etc-gpt-bb1",
         sizes: etcgptbb1Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptbb1Mapping ) : [[300,250],[300,600]]      });
          var etcgptbb2Mapping = typeof( gpt_ad_slots["etc-gpt-bb2"] ) !== 'undefined' ? gpt_ad_slots["etc-gpt-bb2"].mapping : false;
      biddingSlots.push({
         slotID: "etc-gpt-bb2",
         slotName: "\/6872\/shaw.etcanada.com\/942064\/music\/etc-gpt-bb2",
         sizes: etcgptbb2Mapping ? ETC_APS_Helper.parseSizeMappings( etcgptbb2Mapping ) : [300,250]      });
    
    apstag.fetchBids({
      slots: biddingSlots, 
      timeout: 1200
    }, function(bids) {
      // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration 
      googletag.cmd.push(function(){
        apstag.setDisplayBids();
        googletag.pubads().refresh();
      });
    });
  });
</script>
    	
    		<style>
		div.box-label,
		.kicker {
			color:#2397ff; 
					}
		h2.heading {
											}
		h2.heading span.accent {
			color:#0060b6; 
		}
		
		ul.content-list a:hover, ul.content-list a:hover .headline,
		.hoverable:hover > span, .hoverable:focus > span, .hoverable a:hover, .hoverable a:focus {
			color:#0075df !important; 
		}
		.content-wrapper a, .article-wrapper a {
			color:#0075df; 
		}
		div.load-more {
								}
		
		
	</style>
	
			
		<script type="text/javascript" async="async" src="//sdk.sharethrough.com/gc.js"></script>

						<script type="text/javascript" src="https://assets.adobedtm.com/launch-EN6bb9ef052fe24388b9d1ae37a0dd4e00.min.js" async></script>
					
	</head>
	<body class="post-template-default single single-post postid-942064 single-format-standard">
		<script>
	  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	  ga('create', "UA-43818396-1", 'auto');
	  ga('send', 'pageview');

	</script>
	
				<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "\/\/connect.facebook.net\/en_US\/sdk.js#xfbml=1&appId=508564806021134&version=v2.6";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>
		
	<!-- LEADERBOARD -->
		<div class="ad-container" data-sticky-container >
		<section data-sticky data-sticky-on="small" data-margin-top="0" data-anchor="content" class="leaderboard sticky" aria-label="leaderboard section">	<div id="etc-gpt-lb1" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-lb1");
			});
		</script>
	</div>
	</section>	</div>
	
	<div id="header" class="nav-wrapper single-nav" data-sticky-container>
	<nav data-sticky data-sticky-on="small" data-anchor="content" data-margin-top="0" style="width:100%" aria-label="Main site navigation">
		<div class="top-bar">
			<a class="skip-to-main" href="#content">Skip to Main Content</a>
			<div class="top-bar-title">
				<a class="logo-link" href="https://etcanada.com/">
					<img class="logo" src="https://etcanada.com/wp-content/uploads/2019/08/etcanada-blue.png?w=90" alt="ET Canada"/>
				</a>
			</div>
			<div>
				<div class="top-bar-left">
					<div id="site-menu" class="menu-items" data-toggler=".active">
						<div class="menu-dropdown-wrapper" id="header-dropdown-toggle">
							<button class="menu-toggle hoverable" data-toggle="site-menu" data-track-name="dropdown.open" data-track-value="true" data-track-desc="dropdown menu toggle">
								<span class="icon-menu"><span class="sr-only">open</span></span>
								<span class="icon-close"><span class="sr-only">close</span></span>
								<span class="heading"> SECTIONS</span>
							</button>
							<ul class="menu menu-dropdown hoverable" id="header-dropdown-menu">
								<li class="search" id="header-dropdown-search">
									<form class="search-form" method="get" action="/">
										<label class="sr-only" for="search-input-mobile">Search site content</label>
										<input id="search-input-mobile" type="text" name="s" placeholder="SEARCH" value="" autocomplete="off">
										<input type="hidden" name="video-search" value="0">
										<button type="submit" class="hollow button icon-search">
											<span class="sr-only">Search</span>
										</button>
									</form>
								</li>
								<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
								<li class="social" id="header-dropdown-social">
									<div>
										<a class="icon-facebook" href="//facebook.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | facebook" data-track-value="facebook"><span class="sr-only">facebook</span></a><a class="icon-twitter" href="//twitter.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | twitter" data-track-value="twitter"><span class="sr-only">twitter</span></a><a class="icon-instagram" href="//instagram.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | instagram" data-track-value="instagram"><span class="sr-only">instagram</span></a><a class="icon-youtube" href="https://www.youtube.com/c/etcanadaofficial" data-track-name="social.exit" data-track-desc="exit to social channel | youtube" data-track-value="youtube"><span class="sr-only">youtube</span></a><a class="icon-linkedin" href="https://www.linkedin.com/company/et-canada/" data-track-name="social.exit" data-track-desc="exit to social channel | linkedin" data-track-value="linkedin"><span class="sr-only">linkedin</span></a>									</div>
								</li>
								<li class="ad-choices">
									<a href="http://www.corusent.com/privacy-policy/#adchoices" target="_blank" rel="noreferrer">
										<div class="sr-only">Ad Choices</div>
										<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/ad-choices.png" alt="">
										<span>Ad Choices</span>
									</a>
								</li>
							</ul>
						</div>
						<div class="menu-links-wrapper hoverable">
							<ul id="header-menu" class="menu-links"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
</ul>						</div>
					</div>
					
																<div class="trending-items hoverable" id="header-trending">
							<div class="box-label">TRENDING NOW</div>
							<ul>
								<li><a href="https://etcanada.com/news/942005/aaron-carter-found-dead-at-34/">Aaron Carter</a></li><li><a href="https://etcanada.com/news/941962/rebel-wilson-and-ramona-agruma-are-engaged-after-less-than-a-year-of-dating/">Rebel Wilson</a></li><li><a href="https://etcanada.com/news/941922/black-panther-director-ryan-coogler-recalls-how-tired-chadwick-boseman-was-during-their-final-conversation/">Ryan Coogler</a></li><li><a href="https://etcanada.com/news/941776/keanu-reeves-was-surprised-by-matthew-perrys-insults-report/">Keanu Reeves</a></li><li><a href="https://etcanada.com/news/942006/chris-redd-breaks-silence-on-brutal-attack-outside-nyc-comedy-club-snl-alum-was-gushing-blood/">Chris Redd</a></li><li><a href="https://etcanada.com/news/942038/millie-bobby-brown-reveals-why-shes-scared-to-begin-filming-stranger-things-5-following-enola-holmes-2/">Millie Bobby Brown</a></li><li><a href="https://etcanada.com/news/941809/prince-william-reportedly-has-an-idea-to-break-the-mould-and-shift-the-dial-when-it-comes-to-royal-engagements/">Prince William</a></li>							</ul>
						</div>
														</div>
				<div class="top-bar-right">
						<div class="ad-choices">
							<a href="http://www.corusent.com/privacy-policy/#adchoices" target="_blank" rel="noreferrer">
								<div class="sr-only">Ad Choices</div>
								<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/ad-choices.png" alt=""> <span>Ad Choices</span>
							</a>
						</div>
					<form class="search-form" method="get" action="/" id="header-search">
						<label class="sr-only" for="search-input-desktop">Search site content</label>
						<input id="search-input-desktop" type="text" name="s" placeholder="Search" value="" autocomplete="off">
						<input type="hidden" name="video-search" value="0">
						<button type="submit" class="hollow button icon-search">
							<span class="sr-only">Search</span>
						</button>
					</form>
					<div class="social-icons hoverable" id="header-social">
													<a class="icon-facebook" 
								href="//facebook.com/etcanada" 
								data-track-name="social.exit" 
								data-track-desc="exit to social channel | facebook" 
								data-track-value="facebook"
							>
								<span class="sr-only">ETCanada facebook</span>	
							</a>
													<a class="icon-twitter" 
								href="//twitter.com/etcanada" 
								data-track-name="social.exit" 
								data-track-desc="exit to social channel | twitter" 
								data-track-value="twitter"
							>
								<span class="sr-only">ETCanada twitter</span>	
							</a>
													<a class="icon-instagram" 
								href="//instagram.com/etcanada" 
								data-track-name="social.exit" 
								data-track-desc="exit to social channel | instagram" 
								data-track-value="instagram"
							>
								<span class="sr-only">ETCanada instagram</span>	
							</a>
											</div>
				</div>
			</div>
							<div class="article-social">
					
<ul class="social-share" data-social-share-url="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/" data-social-share-title="Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217;">
	<li class="facebook" title="Share this on Facebook" data-social-share-provider="facebook">
		<a class="icon-facebook"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on facebook" 
			data-track-value="share|facebook" 
			data-track-page="true" 
			href="//www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F" 
		>
			<span class="sr-only">Click to share this on Facebook</span>
		</a>
	</li>
	<li class="twitter" title="Share this on Twitter" data-social-share-provider="twitter">
		<a class="icon-twitter"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on twitter" 
			data-track-value="share|twitter" 
			data-track-page="true" 
			href="//twitter.com/intent/tweet?text=Dolly%20Parton%20Inducted%20Into%20Rock%20%26%20Roll%20Hall%20Of%20Fame%3A%20%E2%80%98I%E2%80%99m%20A%20Rock%20Star%20Now%21%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F" 
		>
			<span class="sr-only">Click to share this on Twitter</span>
		</a>
	</li>
	<li class="email" title="Email this page to a friend" data-social-share-provider="email">
		<a class="icon-email"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on email" 
			data-track-value="share|email" 
			data-track-page="true" 
			href="mailto:?Subject=Dolly%20Parton%20Inducted%20Into%20Rock%20%26%20Roll%20Hall%20Of%20Fame%3A%20%E2%80%98I%E2%80%99m%20A%20Rock%20Star%20Now%21%E2%80%99&#038;body=Dolly%20Parton%20Inducted%20Into%20Rock%20%26%20Roll%20Hall%20Of%20Fame%3A%20%E2%80%98I%E2%80%99m%20A%20Rock%20Star%20Now%21%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F" 
		>
			<span class="sr-only">Click to share this via email</span>
		</a>
	</li>
</ul>
					<span class="icon-close"></span>
				</div>
						<div class="spacer"></div>
		</div>
	</nav>
</div>
	<div class="layout-wrapper">
		<main id="content">

	
<div class="column-wrapper">
	<div class="stream">
		<div class="article content-wrapper">
			
<h1>Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217;</h1> <!-- title -->

<div class="byline">
	By <span class="author-name">Brent Furdyk</span>.<!-- Author byine -->
	<span class="byline-datetime">Published: <time>4 hours ago</time></span>
		<span class="byline-datetime">Last updated: <time>4 hours ago</time></span>
	</div>

<!-- Social share buttons -->
<div class="sticky-social-wrapper" data-sticky-container id="article-social-share">
	<div class="sticky-social" data-sticky data-sticky-on="xxlarge" data-anchor="content">
		
<ul class="social-share" data-social-share-url="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/" data-social-share-title="Dolly Parton Inducted Into Rock &#038; Roll Hall Of Fame: &#8216;I&#8217;m A Rock Star Now!&#8217;">
	<li class="facebook" title="Share this on Facebook" data-social-share-provider="facebook">
		<a class="icon-facebook"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on facebook" 
			data-track-value="share|facebook" 
			data-track-page="true" 
			href="//www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F" 
		>
			<span class="sr-only">Click to share this on Facebook</span>
		</a>
	</li>
	<li class="twitter" title="Share this on Twitter" data-social-share-provider="twitter">
		<a class="icon-twitter"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on twitter" 
			data-track-value="share|twitter" 
			data-track-page="true" 
			href="//twitter.com/intent/tweet?text=Dolly%20Parton%20Inducted%20Into%20Rock%20%26%20Roll%20Hall%20Of%20Fame%3A%20%E2%80%98I%E2%80%99m%20A%20Rock%20Star%20Now%21%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F" 
		>
			<span class="sr-only">Click to share this on Twitter</span>
		</a>
	</li>
	<li class="email" title="Email this page to a friend" data-social-share-provider="email">
		<a class="icon-email"
			target="_blank" 
			rel="noreferrer" 
			data-track-rule="contentShare" 
			data-track-name="content.share" 
			data-track-desc="share on email" 
			data-track-value="share|email" 
			data-track-page="true" 
			href="mailto:?Subject=Dolly%20Parton%20Inducted%20Into%20Rock%20%26%20Roll%20Hall%20Of%20Fame%3A%20%E2%80%98I%E2%80%99m%20A%20Rock%20Star%20Now%21%E2%80%99&#038;body=Dolly%20Parton%20Inducted%20Into%20Rock%20%26%20Roll%20Hall%20Of%20Fame%3A%20%E2%80%98I%E2%80%99m%20A%20Rock%20Star%20Now%21%E2%80%99%20https%3A%2F%2Fetcanada.com%2Fnews%2F942064%2Fdolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now%2F" 
		>
			<span class="sr-only">Click to share this via email</span>
		</a>
	</li>
</ul>
	</div>
</div>

<figure class="featured-image">
		<img 
		data-interchange="[https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1439411083.jpg?quality=80&amp;strip=all&amp;w=450&amp;h=300&amp;crop=1, small], [https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1439411083.jpg?quality=80&amp;strip=all&amp;w=720&amp;h=480&amp;crop=1, not-small]"
		src="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1439411083.jpg?quality=80&#038;strip=all&#038;w=720&#038;h=480&#038;crop=1"
		alt="Inductee Dolly Parton performs onstage during the 37th Annual Rock &amp; Roll Hall of Fame Induction Ceremony at Microsoft Theater on November 05, 2022 in Los Angeles, California. "/>
	 
			<figcaption>
			<span>Inductee Dolly Parton performs onstage during the 37th Annual Rock &amp; Roll Hall of Fame Induction Ceremony at Microsoft Theater on November 05, 2022 in Los Angeles, California. </span>
							<cite>&mdash; Photo by Kevin Mazur/Getty Images for The Rock and Roll Hall of Fame</cite> 
					</figcaption>
	</figure>
<article id="article-body" class="article-body">
	<!-- story content -->
	<p>Dolly Parton was inducted into the Rock and Roll Hall of Fame on Saturday night, concluding a journey in which she initially attempted to withdraw from consideration before subsequently agreeing to the honour.</p>
<p>Introduced by Pink, Parton delivered a rousing speech that served as a keen reminder of why the legendary country music singer and songwriter is a rocker at heart.</p>
<p>“I’m a rock star now!” Parton began, as reported by <a href="https://www.rollingstone.com/music/music-news/dolly-parton-rock-hall-induction-speech-1234624706/"><em>Rolling Stone</em></a>.</p>
		<p>
		<strong>
			READ MORE: 			<a href="https://etcanada.com/news/891240/dolly-parton-backtracks-and-says-she-would-gracefully-accept-rock-hall-induction/" target="_blank" rel="noreferrer">
				Dolly Parton Backtracks And Says She Would &#8216;Gracefully&#8217; Accept Rock Hall Induction			</a>
		</strong>
		</p>
		
<p>“This is a very special night for me,&#8221; she continued. &#8220;I’m sure a lot of you knew that back when they said they were gonna put me in the Rock and Roll Hall of Fame, I didn’t feel like I had done enough to deserve that. And I didn’t understand at the time that it’s about more than that. But I’m just so honoured and so proud to be here tonight.”</p>
<p>Among the highlights was Pink teaming up with Brandi Carlile for a performance of Parton&#8217;s classic &#8220;Coat of Many Colors&#8221;.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">P!NK &amp; BRANDI CARLILE SINGING COAT OF MANY COLOR AT DOLLY PARTON&#39;S  HALL OF FAME CEREMONY <a href="https://twitter.com/hashtag/pink?src=hash&amp;ref_src=twsrc%5Etfw">#pink</a> <a href="https://twitter.com/hashtag/brandicarlile?src=hash&amp;ref_src=twsrc%5Etfw">#brandicarlile</a> <a href="https://twitter.com/hashtag/coatofmanycolors?src=hash&amp;ref_src=twsrc%5Etfw">#coatofmanycolors</a> <a href="https://twitter.com/hashtag/dollyparton?src=hash&amp;ref_src=twsrc%5Etfw">#dollyparton</a> <a href="https://t.co/B3y9UQCT8H">pic.twitter.com/B3y9UQCT8H</a></p>
<p>&mdash; M (@babbelaar__) <a href="https://twitter.com/babbelaar__/status/1589260691508441091?ref_src=twsrc%5Etfw">November 6, 2022</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Parton also took part in the traditional jam session, performing her hit “Jolene” with Pink and Brandi Carlile, joined by fellow inductees Pat Benatar, Duran Duran frontman Simon LeBon, Rob Halford of Judas Priest, and Eurythmics duo Annie Lennox and Dave Stewart.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/RockAndRollHallOfFame?src=hash&amp;ref_src=twsrc%5Etfw">#RockAndRollHallOfFame</a> <a href="https://twitter.com/DollyParton?ref_src=twsrc%5Etfw">@DollyParton</a> Superstar Jammin session of Jolene absolutely amazing 🎸<a href="https://twitter.com/hashtag/Pink?src=hash&amp;ref_src=twsrc%5Etfw">#Pink</a> <a href="https://twitter.com/Pink?ref_src=twsrc%5Etfw">@Pink</a> <a href="https://twitter.com/AnnieLennox?ref_src=twsrc%5Etfw">@AnnieLennox</a> <a href="https://t.co/gLz4UKrKWO">pic.twitter.com/gLz4UKrKWO</a></p>
<p>&mdash; Kerry (@kerrykez30) <a href="https://twitter.com/kerrykez30/status/1589188854845952000?ref_src=twsrc%5Etfw">November 6, 2022</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Parton also strapped on an electric guitar to debut a new song she&#8217;d written for the occasion, titled “Rockin’,” which she performed backed by the Zac Brown Band.</p>
<p>“If I’m going to go in the Rock and Roll Hall of Fame, I’m going to have to earn it,” she said. “And you thought I couldn’t rock and roll.”</p>
		<p>
		<strong>
			READ MORE: 			<a href="https://etcanada.com/news/893132/dolly-parton-wants-to-sing-hardest-style-rock-n-roll-song-if-she-attends-rock-roll-hall-of-fame-ceremony/" target="_blank" rel="noreferrer">
				Dolly Parton Wants To Sing &#8216;Hardest Style Rock &#8216;N&#8217; Roll Song&#8217; If She Attends Rock &#038; Roll Hall Of Fame Ceremony			</a>
		</strong>
		</p>
		
<p>Interviewed on the red carpet, Parton revealed that she&#8217;s planning on recording her first-ever rock album.</p>
<p>&#8220;Well, I&#8217;m excited, I&#8217;m doing a rock &#8216;n&#8217; roll album,&#8221; Parton said. &#8220;The time is right, time is everything. I had always thought I might do one, but I hadn&#8217;t thought about doing it right now.&#8221;</p>
<p>Her induction in the Rock and Roll Hall of Fame, however, led her to feel that time had come. &#8220;But I thought, well, why not now? I mean, with all the hoopla and all the craziness that went on around this, so I&#8217;m gonna do it.&#8221;</p>
		<p>
		<strong>
			READ MORE: 			<a href="https://etcanada.com/news/940257/dolly-parton-retiring-from-the-road-i-do-not-think-i-will-ever-tour-again/" target="_blank" rel="noreferrer">
				Dolly Parton Retiring From The Road: &#8216;I Do Not Think I Will Ever Tour Again&#8217;			</a>
		</strong>
		</p>
		
<p>According to Parton, her album will feature a mixture of rock classics and some originals, along with some special guests. &#8220;I&#8217;m gonna do a lot of classic songs, I&#8217;ve written a few rock songs, and I&#8217;m gonna have a lot of the icons sing with me,&#8221; she said.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">DOLLY ROCKER: Country star <a href="https://twitter.com/DollyParton?ref_src=twsrc%5Etfw">@dollyparton</a> is inducted into the Rock and Roll Hall of Fame and reveals she plans to release her first rock album. <a href="https://t.co/r1kw7eXxfi">pic.twitter.com/r1kw7eXxfi</a></p>
<p>&mdash; AP Entertainment (@APEntertainment) <a href="https://twitter.com/APEntertainment/status/1589227948133027841?ref_src=twsrc%5Etfw">November 6, 2022</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Highlights from the ceremony at the Microsoft Theater in L.A. — which also featured the inductions of Eminen, Duran Duran, Lionel Richie, Pat Benatar, Eurythmics,and Carly Simon — will air Saturday, Nov. 19 on HBO.</p>
		<div class="flex-video widescreen">
  			<iframe class="etc-vid" 
  				width="692" 
  				height="389" 
  				src="https://etcanada.com/embed/442df942-5dec-11ed-bfb1-0242ac110005/?autoPlay=false" 
  				frameborder="0" 
  				allowfullscreen 
  				scrolling="no" 
  				title="Video: Dolly Parton Is Recording A Rock Album" 
  			></iframe>
		</div>
		

	<!-- story ad -->
	<section  class="story-ad" aria-label="story ad section">	<div id="etc-gpt-bb2" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-bb2");
			});
		</script>
	</div>
	</section></article>

<!-- article tags -->
	<aside id="article-tags" class="story-tags" aria-label="Article tags">
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/dolly-parton/">Dolly Parton</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/music/">Music</a><!--
			--></span>
								<span class="story-tag"><!--
				--><a href="https://etcanada.com/tag/rock-and-roll-hall-of-fame/">Rock and Roll Hall of Fame</a><!--
			--></span>
			</aside>

<!-- outbrain stories -->

<div class="OUTBRAIN" data-src="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/" data-widget-id="STORY_1" data-ob-template="ETCanada" ></div>

<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<!-- newsletter signup -->
	<section id="article-newsletter-signup" class="newsletterSignup newsletterSignup--article" aria-label="Newsletter signup">
		<a href="https://etcanada.com/newsletters-sign-up/" target="_blank" rel="noreferrer" data-track-name data-track-value data-track-desc="newsletter signup">
			<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/newsletter/newsletter-large.jpg" alt="Get breaking news in your inbox" />
		</a>
	</section>
	
<!-- article related -->

<div class="OUTBRAIN" data-src="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/" data-widget-id="AR_2" data-ob-template="ETCanada" ></div>

<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script><section id="article-related-stories" class="featured-story-list" aria-label="Related stories section"><h2 class="heading">Related </h2><ul class="content-list related"><li>
	<a href="https://etcanada.com/news/942103/paul-mescal-confirms-engagement-to-phoebe-bridgers/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1395107080.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin" alt="">
					</div>
		<h3 class="headline">Paul Mescal Confirms Engagement To Phoebe Bridgers</h3>                    
	</a>
</li><li>
	<a href="https://etcanada.com/news/942089/harry-styles-postpones-3-shows-due-to-flu-im-devastated/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1393470391.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin" alt="">
					</div>
		<h3 class="headline">Harry Styles Postpones 3 Shows Due To Flu: &#8216;I&#8217;m Devastated&#8217;</h3>                    
	</a>
</li><li>
	<a href="https://etcanada.com/news/942081/duran-duran-guitarist-andy-taylor-reveals-stage-4-prostate-cancer-there-is-no-cure/">
		<div class="img-wrapper">
							<img src="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-663791606.jpg?quality=80&#038;strip=all&#038;w=387&#038;h=258&#038;crop=1" nopin="nopin" alt="">
					</div>
		<h3 class="headline">Duran Duran Guitarist Andy Taylor Reveals Stage 4 Prostate Cancer: &#8216;There Is No Cure&#8217;</h3>                    
	</a>
</li></ul></section>



<!-- pinterest footer code for pinit buttons -->
<script async defer data-pin-hover="true" src="//assets.pinterest.com/js/pinit.js"></script>
			<!-- OUTBRAIN RELATED CONTENT -->

			<!-- COMMENTS -->
							<a name="respond"></a>
				<h2 class="heading">Comments </h2>				<div id="comments-container">
						<div class="fb-comments" data-href="https://etcanada.com/news/942064/dolly-parton-inducted-into-rock-roll-hall-of-fame-im-a-rock-star-now/" data-numposts="5" data-colorscheme="light" data-width="100%" data-order-by="reverse_time" ></div>
					</div>
					</div>
	</div><!-- END: stream -->

	<aside class="wells" aria-label="Sidebar">
		<section  class="sidebar-ad widget" aria-label="sidebar ad widget section">	<div id="etc-gpt-bb1" class="ad" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-bb1");
			});
		</script>
	</div>
	</section><section class="widget image-link" aria-label="Sidebar ad section">
		<div id="etc-gpt-band1" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band1");
			});
		</script>
	</div>
		<div id="etc-gpt-band2" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band2");
			});
		</script>
	</div>
		<div id="etc-gpt-band3" class="ad-band" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-band3");
			});
		</script>
	</div>
	</section>
<!-- Microsites --><section class="widget image-link" aria-label="Sidebar image links" data-id="sidebar-image-link">					<a href="https://etcanada.com/tag/the-rings-of-power/">
						<span class="sr-only">The Rings Of Power</span>
						<img src="https://etcanada.com/wp-content/uploads/2022/09/web-MYSTIC-RAISIN-BRICK-340x150-co-brand.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1" alt="" />
					</a>
									<a href="https://etcanada.com/tag/royals/">
						<span class="sr-only">Royals</span>
						<img src="https://etcanada.com/wp-content/uploads/2020/02/royals-brick-340x150-1.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1" alt="" />
					</a>
									<a href="https://etcanada.com/tag/country-club/">
						<span class="sr-only">Country Club</span>
						<img src="https://etcanada.com/wp-content/uploads/2022/09/Ford_CCMA_ETC_Country_Club_340x150.jpg?quality=80&#038;strip=all&#038;w=340&#038;h=150&#038;crop=1" alt="" />
					</a>
						<a href="https://etcanada.com/videos/">
			<img src="https://etcanada.com/wp-content/uploads/2022/06/5b7753aa-7d67-4aee-a43e-ade8290ecb41.jpg?quality=80&strip=all" alt="ET Canada - One on One with Carrie Underwod" />
		</a>
		</section>		<section class="widget side-posts-widget" aria-label="Sidebar popular stories" id="sidebar-popular-posts">
			<h2 class="heading">Most <span class="accent">Popular </span>Stories </h2>	
			<ul class="content-list">		
			
			<li class="media-object">
	<a href="https://etcanada.com/news/942005/aaron-carter-found-dead-at-34/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					1				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1164666607.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					Aaron Carter Found Dead At 34				</div>
			</div>
		</div>
	</a>
</li><li class="media-object">
	<a href="https://etcanada.com/news/942038/millie-bobby-brown-reveals-why-shes-scared-to-begin-filming-stranger-things-5-following-enola-holmes-2/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					2				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1244284454.jpg?quality=80&#038;strip=all&#038;w=145&#038;h=97&#038;crop=1" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					Millie Bobby Brown Reveals Why She&#8217;s Scared To Begin Filming &#8216;Stranger Things 5&#8217; Following &#8216;Enola Holmes 2&#8217; 				</div>
			</div>
		</div>
	</a>
</li><li class="media-object">
	<a href="https://etcanada.com/news/942034/aaron-carters-ex-melanie-martin-tearfully-reacts-to-news-of-his-death/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					3				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2022/11/GettyImages-1370262396.jpg?quality=80&#038;strip=all&#038;crop=414px%2C244px%2C2143px%2C1432px&#038;resize=145%2C97" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					Aaron Carter&#8217;s Ex Melanie Martin Tearfully Reacts To News Of His Death				</div>
			</div>
		</div>
	</a>
</li><li class="media-object">
	<a href="https://etcanada.com/news/942041/aaron-carters-final-album-to-be-released-on-nov-6/">
		<div class="media-object-section img-section">
			<div class="thumbnail ">
							<div class="box-label">
					4				</div>
						    
							<img src="https://etcanada.com/wp-content/uploads/2022/09/shutterstock_editorial_12070322m.jpg?quality=80&#038;strip=all&#038;crop=945px%2C562px%2C2496px%2C1670px&#038;resize=145%2C97" style="max-width:145px;" alt="" />
						</div>
		</div>
		<div class="media-object-section">
			<div class="excerpt">
				<div class="side-posts-heading">
					Aaron Carter&#8217;s Final Album To Be Released On Nov. 6				</div>
			</div>
		</div>
	</a>
</li>			</ul>
		</section>
		

<section class="widget side-posts-widget" aria-label="Sidebar latest videos" id="sidebar-latest-videos">
	<a class="heading-link" href="https://etcanada.com/video/">
		<h2 class="heading">Latest <span class="accent">Videos </span></h2>	
	</a>

	<ul class="content-list">
					<li class="media-object">
				<a href="https://etcanada.com/video/GLOB0056780680000000/nov-04-2022/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i1.wp.com/media.globaltv.com/videostatic/vms/GlobalTV/GLOB0056780680000000/GLOB0056780680000011_1_thumbnail.jpeg?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Nov/04/2022	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/e3ada19e-5df5-11ed-9117-0242ac110003/lionel-richie-talks-rock-hall-of-fames-new-inclusiveness/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i1.wp.com/media.globaltv.com/videostatic/vms/5u0jsbx5zy-3ajcdbu2ne/ETC11062022LionelRichie.png?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Lionel Richie Talks Rock Hall Of Fame’s New Inclusiveness	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/036f0fd8-5def-11ed-b6ee-0242ac110003/king-charles-hosts-cop27-reception-at-buckingham-palace/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i1.wp.com/media.globaltv.com/videostatic/vms/ztmyv6y1w1-b2zeoywel1/ETC11062022Royals.png?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								King Charles Hosts COP27 Reception At Buckingham Palace	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/442df942-5dec-11ed-bfb1-0242ac110005/dolly-parton-is-recording-a-rock-album/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i1.wp.com/media.globaltv.com/videostatic/vms/50q2n9nsgd-zu0fmbe3li/ETC11062022DollyPartonYoutube.png?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Dolly Parton Is Recording A Rock Album	
							</div>
						</div>
					</div>
			  	</a>
			</li>
					<li class="media-object">
				<a href="https://etcanada.com/video/GLOB0056780670000000/nov-03-2022/">
					<div class="media-object-section img-section">
						<div class="thumbnail icon-play">
							<img src="https://i0.wp.com/media.globaltv.com/videostatic/vms/GlobalTV/GLOB0056780670000000/GLOB0056780670000011_1_thumbnail.jpeg?w=145&#038;h=97&#038;quality=60" alt="">
						</div>
					</div>
					<div class="media-object-section">
						<div class="excerpt">
							<div class="side-posts-heading">
								Nov/03/2022	
							</div>
						</div>
					</div>
			  	</a>
			</li>
			</ul>
</section>

<section class="widget image-link" aria-label="Sidebar link A">
	</section><section class="widget image-link" aria-label="Sidebar link B">
	</section><section class="widget image-link" aria-label="Sidebar link C">
	</section>	<section id="search-1" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://etcanada.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></section>	</aside>
</div><!-- END: column-wrapper -->


		</main>
	</div><!-- END: layout-wrapper -->
	
	<!-- Wallpaper Ad Call -->
	<script>
		function cwChangeWallpaperAd(url, hex) {
			if ( typeof (url) === 'string' ) {
				jQuery('body').css("background", hex + " url(" + url + ") no-repeat center 120px");
			}
		}
		function cwChangeWallpaperAdFixed( $url, $hex, $attachment ) {
			if ( typeof ( $url ) === 'string' ) {
				jQuery( 'body' ).css( 'background', $hex + ' url(' + $url + ') no-repeat' );
				if ( $attachment && $attachment === true ) {
					jQuery( 'body' ).css( 'background-attachment', 'fixed' ).css( 'background-position', 'center top' );
				} else {
					jQuery( 'body' ).css( 'background-position', 'center 120px' );
				}
			}
		}
		function cwChangeWallpaperAdScrollOption( $url, $hex, $attachment ) {
			if ( $attachment !== undefined && $attachment === true ) {
				cwChangeWallpaperAdFixed( $url, $hex, $attachment );
			} else {			
				cwChangeWallpaperAd( $url, $hex );
			}
		}
	</script>

	
		<div id="etc-gpt-wall" class="" >
		<script type='text/javascript'>
			googletag.cmd.push(function() {
				googletag.display("etc-gpt-wall");
			});
		</script>
	</div>
	
	<footer>
	<section id="footer-showtimes" class="showtimes" aria-label="Showtimes information">
		<div>
			<a class="global-logo" href="https://www.globaltv.com">
				<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/global.png" alt="Global TV" />
			</a>
			<a class="etc-logo" href="https://etcanada.com">
				<img src="https://etcanada.com/wp-content/uploads/2019/08/etcanada-blue.png?w=82" alt="ET Canada" />
			</a>
			<div class="info">
				<div class="date">WEEKNIGHTS</div>
				<div class="time">7:30 ET</div>
			</div>
		</div>
	</section>
	<nav aria-label="Footer navigation">
		<ul class="menu" id="footer-menu">
			<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35"><a href="/">Home</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36"><a href="/video/">Video</a></li>
<li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37"><a href="/photos/">Photos</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://etcanada.com/celebs/">Celebs</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://etcanada.com/movies/">Movies</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40"><a href="https://etcanada.com/music/">Music</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://etcanada.com/tv/">TV</a></li>
<li  class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="https://etcanada.com/style/">Style</a></li>
			<li class="social" id="footer-social">
				<div>
											<a class="icon-facebook" href="//facebook.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | facebook" data-track-value="facebook">
							<span class="sr-only">ETCanada facebook</span>
						</a>
											<a class="icon-twitter" href="//twitter.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | twitter" data-track-value="twitter">
							<span class="sr-only">ETCanada twitter</span>
						</a>
											<a class="icon-instagram" href="//instagram.com/etcanada" data-track-name="social.exit" data-track-desc="exit to social channel | instagram" data-track-value="instagram">
							<span class="sr-only">ETCanada instagram</span>
						</a>
											<a class="icon-youtube" href="https://www.youtube.com/c/etcanadaofficial" data-track-name="social.exit" data-track-desc="exit to social channel | youtube" data-track-value="youtube">
							<span class="sr-only">ETCanada youtube</span>
						</a>
											<a class="icon-linkedin" href="https://www.linkedin.com/company/et-canada/" data-track-name="social.exit" data-track-desc="exit to social channel | linkedin" data-track-value="linkedin">
							<span class="sr-only">ETCanada linkedin</span>
						</a>
									</div>
			</li>
		</ul>
	</nav>
	<section id="footer-corporate" class="corporate-footer" aria-label="Corus corporate links">
		<ul class="hoverable">
			<li><a href="/pages/about/">About Us</a></li>
			<li><a href="http://www.corusent.com/privacy-policy/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Privacy Policy</a></li>
			<li><a href="https://www.shawmedia.ca/copyright.asp" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Copyright</a></li>
			<li><a href="https://www.corusent.com/media-centre/brands/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Corus Entertainment</a></li>
			<li><a href="https://www.corusent.com/advertising/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Advertise</a></li>
			<li><a href="https://www.corusent.com/terms-of-use/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Terms of Use</a></li>
			<li><a href="https://www.corusent.com/terms-and-conditions/" target="_blank" rel="noreferrer" data-track-name data-track-desc="corporate link clicked">Advertising Standard Terms</a></li>
			<li><a href="/notifications/">Notifications</a></li>
			<li>Corus Television</li>
		</ul>

		<a class="corus-logo" href="https://www.corusent.com" data-track-name data-track-desc="corporate link clicked" target="_blank" rel="noreferrer">
			<img src="https://etcanada.com/wp-content/themes/shaw-et-canada/img/logos/corus.png" alt="Corus Entertainment Homepage" />
		</a>

		<div class="copyright"><span>&copy;</span> Corus Entertainment Inc., 2022 All rights reserved.</div>			
	</section>
</footer>

			<script src="https://static.freeskreen.com/ba/31/freeskreen.min.js"></script>
						<script type="text/javascript">
						var _sf_async_config={};
			_sf_async_config.uid = "56730";
			_sf_async_config.domain = "etcanada.com";
			_sf_async_config.useCanonical = "true";
			 _sf_async_config.authors = "Brent Furdyk";
			_sf_async_config.sections = "Celebs, Music";
					(function(){
			        function loadChartbeat() {
					window._sf_endpt=(new Date()).getTime();
					var e = document.createElement('script');
					e.setAttribute('language', 'javascript');
					e.setAttribute('type', 'text/javascript');
					e.setAttribute('src', "\/\/static.chartbeat.com\/js\/chartbeat.js" );
					document.body.appendChild(e);
				  }
				  var oldonload = window.onload;
				  window.onload = (typeof window.onload != 'function') ?
					 loadChartbeat : function() { try { oldonload(); } catch (e) { loadChartbeat(); throw e} loadChartbeat(); };
				})();
		</script>
	<script>
		if ( navigator.serviceWorker ) {
			window.addEventListener( 'load', function() {
									{
						navigator.serviceWorker.register(
							"https:\/\/etcanada.com\/wp.serviceworker",
							{"scope":"\/"}						).then( reg => {
													} );
					}
							} );
		}
	</script>
	<script id='etc-story-processor-js-extra'>
var etc_story_processor_setting = {"frequency":"200"};
</script>
<script id='etc-app-js-extra'>
var etc_app_setting = {"is_tag_manage":"1"};
</script>
<script type="text/javascript" src="https://etcanada.com/_static/??-eJydks1uwzAIx19oxOqkpeuh6rMQ221IHOMZ3Chvv1TtocexCwLE78+HcGsBz1ljVqdjXKI4GXGFqOAxY0A3iUs0uHVEBcql6ZvbLZS7ST7cX1Wu3HJAJc4gpHtZING3rFlQEvl5z1VuEtMzfFqzVLjCnYSGFN3002LduldoUorqoSklMVPCnjCZscQYFq72KUX3K22A4R8k1w1KZR9FuJp4LMW+IuUZtKKfKd9s9J3C/mu3UGxTPrqif6xHAyXS7UVflvOh749fx8/Tdz/9ArpQMWg=" ></script><script src='https://stats.wp.com/e-202244.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.4',blog:'177646860',post:'942064',tz:'-5',srv:'etcanada.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '177646860', '942064' ]);
</script>
		
		
			<script>
				var etcDataLayer = typeof( etcDataLayer ) !== 'undefined' ? etcDataLayer : {};
		
			etcDataLayer["sitesubsection"] = "articles";
			etcDataLayer["sitesubsection"] = "articles|dolly parton inducted into rock roll hall of fame im a rock star now";
			etcDataLayer["sitesubsection2"] = "articles|dolly parton inducted into rock roll hall of fame im a rock star now";
			etcDataLayer["sitesubsection3"] = "articles|dolly parton inducted into rock roll hall of fame im a rock star now";
			etcDataLayer["sitesubsection4"] = "articles|dolly parton inducted into rock roll hall of fame im a rock star now";
		etcDataLayer['sitesection'] = "articles";
	etcDataLayer['pagename'] = "articles|dolly parton inducted into rock roll hall of fame im a rock star now";
	etcDataLayer['contenttitle'] = document.title;
	etcDataLayer['referrer'] = document.referrer;
			etcDataLayer["server"] = "www.etcanada.com";
			etcDataLayer["sitename"] = "etcanada";
			etcDataLayer["contenttype"] = "article";
			etcDataLayer["contentid"] = "etc_942064";
			etcDataLayer["publishdate"] = "2022\/11\/06";
			etcDataLayer["tag"] = "dolly-parton,music,rock-and-roll-hall-of-fame";
			etcDataLayer["category"] = "celebs,music";
			etcDataLayer["hourofday"] = "15";
			etcDataLayer["dayofweek"] = "sunday";
			etcDataLayer["weekdayweekend"] = "weekend";
			</script>
			<section aria-label="Wordpress copyright">
	<a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=etcanada.com" rel="generator nofollow" class="powered-by-wpcom"><img src="https://etcanada.com/wp-content/mu-plugins/vip-helpers/images/vip-powered-dark-small.png?ver=20220317" width="187" height="26" alt="Powered by WordPress VIP" /></a>	</section>
</body>
</html>